Live demo doesn't work for reviewers, what do I do?

Well, my item received another slight slight rejection, and I am not sad about it, which happens that this other rejection they say that the live demonstration does not work, I will leave the details below. :grinning_face_with_smiling_eyes:


direct url is working from my side.
Go to your soft rejected item page and click on live preview, is the live preview button working mean showing your demo?

1 Like

No, even with the reviewer gave the same problem, I read some articles said because the item is in quarantine even without fixing it, but I don’t know, with the reviewer gave the same, see the screenshot that the reviewer sent in my email .

Pls reply :frowning:

May be your server is setting the following header which prevents it from being displayed in an iframe.

X-Frame-Options: SAMEORIGIN

You should either omit the header, or change it to something like below:

X-Frame-Options: ALLOW-FROM

If you are not familiar with X-Frame-Options then contact your webhosting support and let them do this for you.

Look, I’m using ultahost, they configured it, tell me how can I change this, so that it is visible in the iframe.

Yes, I have several plugins for this script, which I have in mind to bring to the envato, the one for live broadcast by screen is the first one, I am having small difficulties.

then you should to share the screenshot to your hosting server support and ask them for help.

Okay, I’ll get in touch, WoWonder uses the same provider, I’ll check this out, and I’ll tell you.

Okay, you tell me that maybe the error said could be this?

you should ask your hosting server support

Okay, maybe that’s the problem, I need to allow codecanyon, otherwise it blocks the connection.

The x-frame issue is by far the most likely (unless the host is blocking traffic from different countries)

As @mgscoder said you should ask the provider, but if it’s budget and shared hosting then there’s no guarantee they will be able to adjust the settings

No, I use ultahost (I think are hospeded in the USA), and he is from the USA, which I believe the mother company (Envato) is hosted in the USA, yes I tested my site on an iframe on localhost and the connection is blocked, probably that is it, have to allow (

Hi @kaikeferraz_dev,

The problem is indeed your website is returning a value for the X-Frame-Options header. You can check this yourself by using an inspector, or at the command line:

$ curl -sI | grep -i x-frame-options

A setting of SAMEORIGIN means that the page can only be the source of an iframe if the iframe is hosted on This is not the case with CodeCanyon, so browsers will refuse to load it.

To fix this, you must have your hosting provider remove the X-Frame-Options response header entirely. The ALLOW-FROM value no longer works in modern browsers, so in order to make it work on the preview page, you need to have that header removed.


Thanks for responding, I already sent them a ticket, they will remove the header, and so I will move on here in the submission.

Look at the modification he made, for me this will not solve, but I will not even resend the item.

check the reply

Hi @kaikeferraz_dev,

Unfortunately, it doesn’t appear to have worked – the header is still present:

$ curl -sI | grep -i x-frame-options

Also visible in the browser’s inspector:

You’ll need to go back to your webhost and show them this. You (and your host) can run either of the above tests to confirm that the fix has been properly implemented. When done right, the X-Frame-Options header will not be present in the response at all.

I’m afraid there isn’t anything we can do from our end to change this – it’s entirely up to you and/or your web hosting provider to allow your site to be iframed.

Good luck!

1 Like

thanks for the help, i have an idea in mind, i was looking and the theme is blocking this, i removed all header, the theme is not mine and the script creator, and another, will be if i make a page confirming if the person wants to go to the demo, and open a new page, it could work, or it is not allowed.