Items not appearing in Envato Elements (Mar/Apr 2022)

I have items which are approved more than 12 hours ago in my dashboard (Elements dashboard, Graphic Templates) but they are still not live on Elements. It looks like the old “bug” is back.

This touched also me. My newest item doesn’t show like a new nor in the newest items. Only possible is find in search.

Yes that’s right “older” projects are not shown as “new” in Envato Elements - I checked and tested on my own skin. In my opinion, this is a bug - report to Envato Stuff as soon as possible.

Same here, I have added 4 items today but don’t appear as new items in Envato Elements.
Could you please check this issue with the team @BenLeong

Still no answer from support. Looks like this is no bug, just new rules.

@BenLeong Can you get interested in this topic?
I have already reported it to support a while ago, but
still nothing has been done. Adding a previously created project to Envato Elements does not appear as new. Previously, when I added any project to Envato Elements, it appeared as new, so there was a minimal chance that it would be noticed by clients. Now there is no such chance … I don’t have to explain to anyone that something is wrong here?

Hi @_miko - I’ll follow up with the Elements team tomorrow, to get an update for you.

I know they began investigating this one when it was initially raised, but I haven’t been following their progress closely.

1 Like

@BenLeong Thanks for your interest in this topic.
I just got a reply …
According to Envato Support, everything is fine …
Unfortunately, this is not true, which I proved by sending screenshots that confirm my thesis. I don’t know how much more I can prove that something is wrong. Projects that are “older”, say for a year on Envato Market and at this point I will add them to Envato Elements, they will not be shown as “new” in Envato Elements. They will be far behind in the hierarchy. I proved it with screenshots.
This was never the case, which is why I reported it. Please check it again.

Hey @_miko I am sorry for the mixed messages here.

I have spoken with the dev team this morning and we can confirm this is a bug. The team is working through this as a priority. We appreciate your patience :pray:


Thanks Will for the update on this.
I think many authors want this to be fixed as soon as possible.


1 Like

@Will4490 do you have any good news for us?
I remember you wrote about a few days and it’s been over a week now and it’s still not fixed yet.

Hey @_miko

I followed-up with our dev team today and this is still an active issue being investigated.

The root cause is known, the team are now working on a fix.

Thanks for your patience.

1 Like

As far as i know, Issue or Bug is “Date of Publishing” in Elements was replaced by “Date of Approval” in the Videohive,
“i.e." If I publish an item approved in Videohive today, it will be listed as new in the first page, Same time if I publish a item that approved in Videohive a month back, it will not get listed as new in first page, Instead will get listed in the page of 20 or 30

That’s right, I explained it from the very beginning … Now another question arises whether and how does this affect the Triple Rewards promotion?
@Will4490 , @BenLeong Can you explain it please? Has anything changed in this topic? How long can it take?

1 Like

Now getting more bad, File is not publishing, it is been 8+ hours, published file not appeared in Elements

1 Like

I have 3 items which are published/approved (several days ago) in my dashboard but they are not live on Elements. But also I have 1 item which is approved after those 3 and that item is visible on Elements.

*Update - I have fixed this. I have “updated” the items and they are now visible on Elements.

Dear Benleong,
Unfortunately I have the same problem.
Some of my items are not appearing in my seller profile after approval.

I faced this issue too

A few days ago I upload an item to Elements. It showed up after one hour. But the next day it disappeared from Elements, and it is still hidden. :man_shrugging:

Definitely a bug, I had same experience week back, I share a secret :innocent: ,Remove Elements Permission of the file and share again after few minutes, It will be back :sunglasses: