FTP Error

Hello guys,

Did someone early facing an error with FTP connection, I have tried today to connect through FTP server but nothing happened.

All I got this error

|Error:|GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.|
|Status:|Server did not properly shut down TLS connection|
|Error:|Could not read from socket: ECONNABORTED - Connection aborted|
|Error:|Could not connect to server|

Any help, please…


you can check this thread hope will help you.
New FTP Credentials(15th May, 2019):

Also please read carefully troubleshooting guide (if you haven’t already) and work through that to see if it helps.


Oh, my bad :man_facepalming: I was using ftp.marketplace.envato.com instead of ftp.author.envato.com

Thanks @mgscoder

1 Like

I have got another issue, this FTP : ftp.author.envato.com for motion graphics upload only… All my upload files moved to motion graphics upload section and I don’t want that, I’m trying to upload After Effects Template…

I have already upload A template before 15 days ago by using this FTP: ftp.marketplace.envato.com … without any issue with the new API…what happened now… I wasted 3 hours just trying to upload a file :sob:
I thought this FTP is not valid anymore ftp.marketplace.envato.com

Please note: If you use the https://author.envato.com/upload (stock video/motion graphics) the Host will be ftp.author.envato.com
otherwise ftp.marketplace.envato.com
If you still is issue then you can create a Personal Token here: https://build.envato.com/create-token/
Use this token as your password in FTP. It is a good idea to create a token specifically for FTP access.

You will need to confirm the following settings:

Protocol: FTP - File Transfer Protocol
Host: ftp.marketplace.envato.com
Encryption: Use explicit FTP over TLS if available
Logon Type: Ask for password
User: <your Envato username here> (this is case-sensitive)
Password: <you will be prompted for the API key>

Alos please check my first reply troubleshooting guide link.

I have already done all these steps you mentioned, Also I have deleted my old token API Key and create another one.

But I still get the same error. :pensive:


In this case please contact Author support and report them. They will check it for you.
In the mean time later today or tomorrow please try again with restart your pc.


1 Like

I’m having trouble accessing the FTP as well, with the correct login credentials. Opening a support ticket to find out if it’s something that needs to be addressed.

UPDATE 1: I generated a new token just in case the old one expired, but I’m still experiencing the same “server closed connection” error.

UPDATE 2: The issue appears to be software-dependent. The Transmit FTP app isn’t working (there were also issues with this program originally when Envato switched to the token system), but after using CyberDuck for Mac, I was able to log in.

1 Like

I’m having the same problem. I had also sent a support ticket. The strange thing is that from my laptop Mac Sierra doesn’t have any problem to get in.

1 Like

I have just downloaded WinSCP and its works fine, I have uploaded the template through it…but with FileZilla isn’t working… it’s kinda wired :thinking: I hope WinSCP has uploaded the files correctly without issues as this is my first time using it

1 Like

I just found the solution. I installed older version of FileZilla and works fine.


Yes, the issue appears to be software-dependent. I have a request out for this to be investigated, so hopefully we’ll have an answer or solution soon.

1 Like

Some issues with the TLS have been updated, and should now be resolved. I tested my typical FTP login method using Transmit (which wasn’t previously working), and I was able to log in.

If you were experiencing problems logging in, check your connections to make sure everything is functional!

1 Like

Today I got FTP issue with this error message

Connection timed out after 20 seconds of inactivity
Could not connect to server

Anyone got same issue?

I can’t connect via FTP
Anyone else having issues?

Update here and sorry for my previous lazy comment.

So there are already other threads dealing with the subject. It might be software related, firewall, ISPs and a mix of all the previous… I really have no clue.

I did find a temporary answer in the link below, where some decided to use a VPN to be able to connect: FTP upload problem.

Really far from ideal, but when you’ve been working non-stop for days on a project and you can’t upload it really feels frustrating.