Deposit not showing


#1

Hi all,

I’ve just made a deposit via Skrill into Envato, but the credit isn’t showing up after the payment has been processed successfully. I’ve got the confirmation for it:

This transaction was funded using your card (VISA, xxxx) on 05 Jun 2014. This charge will appear on your card statement as a debit by: SKR*ENVATO.COM

Merchant Reference:		
 Deposit $50.00 to user cy88 on ThemeForest Deposit $50.00 to user cy88 on ThemeForest

Is there usually a delay?

Thanks!
Chris


#2

Hey Chris!

I’ve just sent you an email :grin:

  • Christian

#3

Wow, that’s quick!

I’ve replied, thanks!


#4

Hi i made a deposit too and it isn’t showing


#5
Dualdottv said

Hi i made a deposit too and it isn’t showing

Hey there,

Our Devs are currently investigating an issue with Skrill deposits. We’ll contact you with more information as soon as possible :grin:

  • Christian

#6
MhW said
Dualdottv said

Hi i made a deposit too and it isn’t showing

Hey there,

Our Devs are currently investigating an issue with Skrill deposits. We’ll contact you with more information as soon as possible :grin:

  • Christian

Thank you. That’s all i wanted to hear


#7

I would like to know the ETA or to get a refund, then repurchase using paypal. Feels like money stolen out of our pocket and we do require to purchase something urgently.


#8

same here, I need to buy something very urgently. Please advice if you are able to do a refund, at least we can use other payment option in the meantime. Hope it doesn’t take that long again to post a simple reply.