The uploaded file exceeds the upload_max_filesize directive in php.ini.


could you please someone help me I want to upload theme to WP the error message will appear “The uploaded file exceeds the upload_max_filesize directive in php.ini.”

theme purchased on envato Market theme name is “Marketo”


Contact your web host

Your web host will need to determine what part of the install process is being limited and increase the limit so that you can install the theme through the WordPress dashboard. Contact their support and let them know you are having problems uploading the theme. Be sure to tell them the size of the file you are trying to upload.

If you have access to server settings or are working on a local server, you can try changing some PHP options yourself in the php.ini file:

  • Set both post_max_size and upload_max_filesize to be larger than the theme file.
  • Ensure memory_limit is generous (256M is recommended).


thank you so helped but I got another error during uploading

The package could not be installed. The theme is missing the style.css stylesheet.

Theme installation failed.

thanks problem was fixed :slight_smile:

1 Like