Photoshop: Can't cut/copy/paste layers?


#1

Hi,

Following last week’s PSD to HTML series I figured I’d dive right in and convert http://themeforest.net/item/blue-commerce-complete-ecommerce-theme/40046 to a HTML template for myself.

However, I can’t seem to be able to copy anything? I checked with other PSD’s, and it’s not just this one.

What I do:

  • Open up the PSD
  • Use the select tool
  • Turn “Auto-Select” on and set to “Layer” instead of “Group”
  • Click the item
  • The layer is highlighted

  • Whatever I do from that point on simply doesn’t work; convert to smart object, cut, copy, paste, nothing works.

Has anyone come across this before?


#2

It’s not that simple to cut copy and paste. You’ll have to CTRL+Click the layer then a marching ants selection forms around the objects on the layer, then you could Cut Copy and paste stuff


#3

Right click (control click) on the layer(s) you want copied, and click “duplicate layers” or select all the layers you want copied and go to Layers > Duplicate Layers. Hope that helps! :slight_smile:


#4

PixeledArt just answered your question, but to make it even clearer:

When CTRL+clicking the layer in your layers palette, you have to click the thumbnail of the layer.

I know it’s a nobrainer for many, and you could discover this for yourself in like 5 seconds, but it’s never bad to be as specific as possible.

I would also recommend downloading Jeffrey’s tutorial and watching it closely - JW makes it sound soooo simple because he’s a pro, but you might miss some things nonetheless (I know I did)

Have fun with it and don’t forget to show us the outcome :wink:


#5

LOL! I knew I had to be something simple. Cmd+click on the thumbnail worked.

I checked the screencast again, but it wasn’t mentioned there (altho Alt-click was, which didn’t work for me?)

Anyway, fixed! Thanks guys :slight_smile:


#6
LOL! I knew I had to be something simple. Cmd+click on the thumbnail worked.

I checked the screencast again, but it wasn’t mentioned there (altho Alt-click was, which didn’t work for me?)

Anyway, fixed! Thanks guys :slight_smile:

JW didn’t mention it, but you can see in the screencast that he clicks the thumbnail.

Anyway, glad you figured it out :slight_smile: