After Effects Glitch ? Solid Disappears.


#1

Hi guys ! hope you're having a good day ^^^
i'm having a little problem in after effects.i have a comp with 3d solids,precomps,camera and stuff.everything went ok untill i moved the camera across one of those 3d layers which is a precomp,a big part of that solild disappeared :/ .. when i set the resolution to half it appears as it should be but once i switch it to full res 40% of the layer disappears.i'm using huge layers and i'm not sure if this may causes this kind of gliches.any advices ? thanks in advance ^_^^


#2

How big your layers are? Maybe it’s a memory problem… Try to purge(Edit->Purge->All) all of your memory…


#3

No it’s not a memory problem i tried to purge the memory and nothing happened,but the layer is really big (19500x3500).i know maybe it’s not the best way to do it,using huge layers is not good,i’ve never do that before but i was just wondering,may that causes those gliches ??


#4

It’s hard to say… Never had that bug before… If you have a chance to share a link to your project, I could see how it runs on my AE…


#5

Can you post a screen shot? It’s not quite clear what you mean by 40% disappears. If it’s a diagonal cut across the layer, it’s possibly something to do with a depth buffer. The layer is pretty huge (although definitely not off-the-scale huge). Are you getting it into shot by having it very far away? Have you tried bringing it close to camera and scaling it down? Is something else intersecting or casting a shadow on it? Are you using a Raytraced comp or a Classic 3D comp? Are you looking through the active camera or a custom camera? Do you have an active camera?

PS It’s a bad idea to use very large images or comp buffers if it’s not necessary. That’s a good way to slow Ae down a lot.


#6

did you try to put a 2d adjustment layer in between your 3d layers ?


#7

Have you tried turning fast previews off?


#8
felt_tips said

Can you post a screen shot? It’s not quite clear what you mean by 40% disappears. If it’s a diagonal cut across the layer, it’s possibly something to do with a depth buffer. The layer is pretty huge (although definitely not off-the-scale huge). Are you getting it into shot by having it very far away? Have you tried bringing it close to camera and scaling it down? Is something else intersecting or casting a shadow on it? Are you using a Raytraced comp or a Classic 3D comp? Are you looking through the active camera or a custom camera? Do you have an active camera?

PS It’s a bad idea to use very large images or comp buffers if it’s not necessary. That’s a good way to slow Ae down a lot.

Yeah i’m putting it far away,there is no shodow on it,and i’m using classic 3d comp settings.i have an active camera and i’m looking trough it.as you said using very latge layer is a bad idea,i don’t usually do that,but i was just wondering.thank you felt ^^


#9
flashato said

did you try to put a 2d adjustment layer in between your 3d layers ?

No ididn't try that before,i will try that out.thank you flashato ^^

#10
andrenavarre said

Have you tried turning fast previews off?

I tried that and nothing really happened :/
Anyway i fixed the problem,the solution is to not use huge layers,it's not good at all.thank you for your response andrenavarre ^^^

felt_tips said

Can you post a screen shot?


#11

it looks like, your ORA layer and back “black” layer are in same Z position.


#12
caneration said

it looks like, your ORA layer and back “black” layer are in same Z position.

No that was only one layer,there is no black layer in the screenshot,that was the disappearing part i was talking about.

#13

I have same problem now and I can’t solve it because my project already complicated and include too many layers :frowning: anyway I think it’s big issue and Adobe have to solve this problem.


#14

I think the trick here is going to be to post a project file and details about your system and version set-up. I think until someone can replicate this, it’s hard to be able to give any advice about how to fix it.

One thing’s for certain - there are small inaccuracies in the z-depth rendering in After Effects (it’s to do with the way it’s calculated (homogenous coordinates) and the numerical precision, I think) but layers that are very close to one another may sometimes render in the wrong order. That would account for your disappearing layer.

It may be more likely with very big or very distant layers (the accuracy of the z-depth reduces further away from camera IIRC). These artefacts may also become more noticeable when motion blur is turned on.


#15
felt_tips said

These artefacts may also become more noticeable when motion blur is turned on.

Exactly, I remember that when i turned MB off the solid looked fine.but sometimes even with the MB off it doesn't look as it should be,maybe it's because of the inaccuracies in the z-depth rendering in After Effects as you said.