We went trough this a bunch of times:
- Please use a unique prefix for all function names, custom images sizes, classes, hooks, public/global variables, and database entries to avoid conflict issues with plugins and other themes. For example, themename_ OR frameworkname_.
- Read more at http://themereview.co/prefix-all-the-things/
- You can still be using frameworkname_ if you are using a framework while using themename_ for your themes.
Now we got soft reject because of:
should be industrial_ not anps_
Where industrial is our new theme name and anps is our framework.
We don’t understand why should we do that???
We have been developping our own framework for 4 years, why should we have to change each function name for each new theme? anps_ prefix is unique since its our author name and it is the name of our framework. I am getting very agitated because of this…!
We can’t understand, why it is OK, to include a framework like option framework or redux and keep function names as they are, but it isn’t allowed to use our own framework name. The thing reviewers should wory about is consistancy about using a prefix, but deciding what this prefix can be or can’t be, seems to us just a bit out of the scope of what individual reviewer should be able to decide on.
Envato has a lot of issue with review times lately and this is a really goood example issue, where Envato could optimize their review process, which would shorten the review time without any consequences in terms of item quality.