Subject not allowed! WP Error

wordpress
themeforest
#1

http://envato.d.pr/Up9FpX/5CZgKo1G -We do not have an error in this file. We can not repeat the error. Write, please, the exact procedure for the occurrence of an error

#2

Set output_buffering to 0 in your php.ini file. Then you’ll probably be able to reproduce it.

#3

Where is he located? We do not have it

#4

Set Wp_Debug “true” at wp-config.php file

1 Like
#5

Depends on what server you’re developing on.

  • A local server? You’ll need to go find it in the server files.
  • A shared/reseller hosting account? Ask your web host how to do this.
  • A cloud server or VPS? Probably somewhere in /etc/php/

I’d enable debugging as @ki-themes’ suggested but I assume you’ve already done this.

The problem the reviewer is showing you is that you’re trying to call header() after output has already been printed out to the page. Perhaps check for redirections you are performing and make sure you’re calling them before any output is sent from any part of WordPress.

A good way to check this is to call die() before the redirection. The page should be entirely blank, including view source. If there’s even a single character or html tag, the error in the screenshot will occur.

Output buffering will prevent this type of error from occurring but output buffering is also off by default in most servers, so you definitely need to find the source of this issue and fix it.