Soft Rejected Due to Redux Ads

My item got another soft rejection, because of ads due to Redux
Reviewer Said :slight_smile:

1: Please remove:

Can any one please let me know.



Hi there,
Add this code
if ( ! function_exists( 'redux_disable_dev_mode_plugin' ) ) { function redux_disable_dev_mode_plugin( $redux ) { if ( $redux->args['opt_name'] != 'redux_demo' ) { $redux->args['dev_mode'] = false; $redux->args['forced_dev_mode_off'] = false; } } add_action( 'redux/construct', 'redux_disable_dev_mode_plugin' ); }
into functions.php


it’s get Soft Rejected Due to Redux Ads . and not the dev_mode . i don’t think tis will solve it .

Ads only display if dev_mode is enabled.

1 Like

This was brought up some time ago, you need to purchase the extension

wow .?? first time a hear this . i didn’t know that redux display Ads if dev_mode is enabled. maybe iam a bad wordpress designer :slight_smile:

There are 2 cases: + localhost + dev_mode is enabled., This theme uses the redux framework, and it has been approved.

Please note guys.

1: If your wordpress Debugging has enabled then Redux Dev Mode will auto true.

2: If you are theme developer always set the dev mode false and then enable the wordpress debug to 1.

Note: Is that reviewer guys debug has enabled? Then it will always displayed and soft rejected for only lost 3 days for nothing and explain to reviewers :stuck_out_tongue: Sometimes we lost 3, 3, 3 days for only fixing one bug…

Its due to the code present there might be!

That’s insane, you have to wait for 3 days just to tell : “Ads are displaying because your are on localhost” :smiley:

@wiloke i have tried this code but its isn’t working, can we use CSS? :stuck_out_tongue:

Hi my item was soft rejected for the same reason. You can find this article helpful, anyways they should now that all Redux notifications & ads are only on localhost or if the dev_mod is enabled.
The end user won’t get those annoying ads

i got soft rejected for the same reason too.
can we use css to hide this ads ???

if we can use css i suggest to go to file : class.redux_admin_notices.php

in line 89 you will find this ( redux-notice notice is-dismissible )
you can add another class and then add to it display none in css

if it was me : i will :smiling_imp: :bomb: :smoking::gun: to the reviewer :head_bandage: