Google maps iframe issue in Chrome


#1

Hey guys, this morning, after a Chrome auto update ( Version 30.0.1599.66 m ), I’m having some problems with an embedded Google map… the map gets stuck on loading, I can’t pan/zoom anymore… anyone having the same problem?

Thanks :slight_smile:


#2

Here is the message in the console: Uncaught SecurityError: Blocked a frame with origin “https://maps.google.it” from accessing a frame with origin “http://www.mysite.com”. The frame requesting access has a protocol of “https”, the frame being accessed has a protocol of “http”. Protocols must match.

I’m literally killing google with my searches but I haven’t been able to find a solution… maybe I should use the javascript google api?

Also I’ve seen a few site templates on sale here having the same problem…


#3

Try adding &output=embed to the end of your iFrame URL, or use GoMap;

http://www.pittss.lv/jquery/gomap/


#4

Hey mate thanks very much for your reply, &output=embed is already there.

This problems also happens on one of your site templates: Other, I haven’t checked more. Check it out with Chrome, can you see the problem in the Contact section where the map is? What version of Chrome have you got?

Regarding GoMap I’m trying to make it working, but do I need to get a Google Api Key first?

Apparently even embedding a simple iframe map has become a problem :frowning:


#5

It is obvious that this is an iframe issue rather then Google Maps itself, maybe a Mod could edit the thread title to make it more appropriate?

The message in the console is quite clear: an https frame (in my case the google maps iframe) is called in an http page, the two protocols do not match and this causes an error… I’ve tried the following:

from
to http://maps.google
and this //maps.google

but it didn’t work…

:S


#6

I have the same problem with Chrome (it seems to be a new problem). Some collegues aren’t able to run it also in Chrome…

In Firefox and IE everything works. Chrome silently breaks this “protocol mismatch” :s

Not exactly awesome for a “popular” browser, i can’t embed Google business Photos


#7
||+900778|abstract-labs said-|| Hey guys, this morning, after a Chrome auto update ( Version 30.0.1599.66 m ), I'm having some problems with an embedded Google map... the map gets stuck on loading, I can't pan/zoom anymore... anyone having the same problem?

Thanks :slight_smile:

You’re not alone/We are not alone :frowning:

http://productforums.google.com/forum/#!topic/maps/hQhwWA56NbA

This sucks!


#8

I uploaded a Symphony theme and it has the same problem. It isn’t reviewed yet, i wrote that it is a Chrome bug in the notes section. Hope it won’t be an issue.


#9

Same issue for me. Nothing fancy with my setup, stopped working in Chrome after update. Still works in IE.


#10

I’ve found the solution in my case by creating a Javascript Google Maps Api Key, with this feature the map will display without any problem and also I could create a custom map to display my client name and address when clicking the marker on the map. :wink:

If your problem is with Google Maps go here: https://developers.google.com/maps/ and follow the instructions to create and use the Api Key.


#11

The Google Maps team fixed it :slight_smile:

https://code.google.com/p/chromium/issues/detail?id=303264


#12

include

before the closing body tag in your code.