Envato Market plugin not updating theme

I have installed Envato Market plugin on two websites, created token and plugin shows updates available for the relevant theme on the site - one is Avada, the other Total.

When I select ‘update available’ the ‘updating’ symbol shows as running, but for ages. Left it for several hours last night and still no green header. Tried refreshing screen, selecting ‘update available’ again, several times, but to no avail.

Does anyone know why it is failing and how I can fix it?

We can’t speak for Avada, but for the Total theme if it’s taking longer than a minute refresh the page and click the update button again. Usually that will work. But if it’s taking longer than 5 minutes the second time around you can contact us for support - https://wpexplorer-themes.com/total/docs/how-to-request-support/

Thanks - got it to work after a few refreshes for Total.

I know Avada’s not yours. Had to update manually via FTP in the end.

Oh good! So glad you got it working :slight_smile:

I just installed the Envato Market, deleted the Toolkit that is deprecated, successfully connected via OAUTH API and updated plugins. When i check my theme Porto it shows version 4.9 but I have version 4.2 installed and no option to update is appearing anywhere. Thoughts?

I would suggest contacting the developer of the theme for support (https://themeforest.net/item/porto-responsive-wordpress-ecommerce-theme/9207399/support).

Though you can force a theme update by activating theme on your website, then going to Appearance > Editor and changing the Version number at the top of the Stylesheet (style.css) file to a lower number. Here’s an example of where to go/what to edit:


So if your theme’s showing 4.9 in Envato Market but you have 4.2 installed you could edit the file to say 4.1. After you save, if you go back to the Envato Market plugin it should show an update as available.

But I would still highly recommend contacting the developer.

Hi dear,

I have an issue with the plugin as well. after doing all steps well and creating my key and save changes, i cant see “update” button on my theme, why is that?

although the developer told me there is an update.