Disable Redux activation redirect

wordpress

#1

My theme uses Redux as a plugin (as per reviewers request). When activating the plugin it redirects to the Redux about page. This interferes with my theme setup workflow and could confuse the user.

Redux uses the following action to redirect:
add_action( ‘init’, array( $this, ‘do_redirect’ ) );

I’ve tried to get around this with remove_action but with no success, anyone else get it right?


#2

Hi,

Try this if updating the plugin doesn’t work.

`add_action( ‘redux/construct’, ‘radium_remove_as_plugin_flag’ );
/**

  • Remove plugin flag from redux. Get rid of redirect
  • @since 1.0.0
    */
    function radium_remove_as_plugin_flag() {
    ReduxFramework::$_as_plugin = false;
    }`

#3

Worked perfectly, thanks a mill!!


#4

Hi
Thank you for open this topic, Do you know how to remove Redux Notices?
Thank you


#5

Add the following to you option-init:
`
add_action( ‘redux/loaded’, ‘remove_demo’ );

/**
 * Removes the demo link and the notice of integrated demo from the redux-framework plugin
 */
if ( ! function_exists( 'remove_demo' ) ) {
    function remove_demo() {
        // Used to hide the demo mode link from the plugin page. Only used when Redux is a plugin.
        if ( class_exists( 'ReduxFrameworkPlugin' ) ) {
            remove_filter( 'plugin_row_meta', array(
                ReduxFrameworkPlugin::instance(),
                'plugin_metalinks'
            ), null, 2 );
            // Used to hide the activation notice informing users of the demo panel. Only used when Redux is a plugin.
            remove_action( 'admin_notices', array( ReduxFrameworkPlugin::instance(), 'admin_notices' ) );            
        }
    }
}

`


#6

Hi

Thank you, I already tried this but the redux notices are still appeared in the admin panel.