C4D Camera Morph to AE?


#1

was trying to get the movement of a camera with the morph tag applied to AE but with no luck. tried baking the frames of the morph tag but looks like is not working.

anyone have a method to do this?

thank you


#2

Hey Doru,

When you try to bake the morph cam, are you getting baked keyframes on the duplicate camera from baking?

It’s working fine for me. I did a quick 2 camera setup and applied morph cam to them. I keyframed the blend attribute in the morph tag and baked. Newly baked camera has keyframes.

Email me if you need help,

cheers,

Vic


#3

thank you for the answer :slight_smile:

I was not clear enough :slight_smile:

I’m trying to see how After Effects CC and Cinema 4D integration works with the Cineware plugin. Looks like the CIneware is not able to extract the camera animation if a camera have the Morph tag applied. Baking keyframes don’t work as the baking is applied to the morph.

But managed to figure a solution. I’ve installed the cinema plugin that let’s you import the aec files in After Effects. This plugin (the old way of importing data in After Effects from c4D) works as expected. It imports the camera animation from a morph camera with no need for baking or other tricks. You can then just cut and paste the camera in the comp where the c4d file is used as layer.

Is too bad I can get it directly when pushing the extract button from cineware.

But I like this new workflow even if is not perfect. Previously, you were forced to render the whole animation from c4d to be able to integrate elements in After Effects. This was time consuming and tens of GB of HD space for storing the various passes rendered from C4d. Now is better, as one can import the c4d files and build the comp around it without the need for render.


#4

I see what you’re saying. The morph tag does translate over to After Effects CC. You don’t have to bake anything.

Are you applying the morph tag manually in the Object Manager or are you selecting the cameras and applying a Camera Morph via the Create menu?

Try selecting your cameras, then going to Create>Camera>Camera Morph. That will give you the Camera Morph setup, keyframe the blend attribute then save it out and open the file in AE. It should work.

I made another test scene with this setup and AE sees the camera animation.


#5
facade said

Are you applying the morph tag manually in the Object Manager or are you selecting the cameras and applying a Camera Morph via the Create menu?

:smiley: manually

wait a minute. let me test this :slight_smile:


#6

doesn’t work :frowning:


#7

Works here.

In the Timeline:

  1. If you have View>Show>“Show Animated” enabled… Disable it. This will show the camera object in the timeline.

  2. In the Timeline, Select the “Morph Camera” Object… Not the “Morph Camera” Tag (Which has the animated Blend).

  3. Select Functions>Bake Objects… Bake.

  4. Import C4D file into AE, Add to scene, Hit “Extract” in Cineware.

  5. Done


#8

lol. whats going on with these old topic recovers.