Adding No CAPTCHA reCAPTCHA to a website.


#1

I was following the Tutorial “How to integrate NoCAPTCHA reCAPTCHA to your website” but when I got to the end (just before the Conclusion) I clicked on “Here’s the final demo” only to be greeted with the message 403 Forbidden, Access denied. Is this vital (for me as a total beginner) piece of information available?
Thanks
Jim


#2

Good point @Jimathy– there seems to be something wrong with our PHP server… I’ll look into it!


#3

@Jimathy while we’re figuring this out, you can always grab the source files, and run them on a PHP localhost on your machine? This free course lesson is specifically about WordPress, but explains how to use MAMP. I hope that helps!


#4

Hi Ian - thanks for the comments. Web design is completely new to me so I’m afraid I’ve no idea what the terms PHP local host and MAMP mean. So far I’ve been designing my website with drag and drop templates that require no knowledge of coding. I think I was doing a reasonable job of following the tutorial so if I could see the “final demo” I might be able to figure out the rest of the CAPTCHA conundrum.
Regards
Jim


#5

Aaah sorry about that @Jimathy, I didn’t realise. We’re still working on the server issue, but in the meantime the best advice I can give you would be to install a PHP server on your system and test the demo files yourself.

If you’re using Windows you can use WAMP and if you‘re using a Mac you can lean on MAMP. In both cases it should be a question of downloading, installing, then running. Make sure in the settings that your new server is pointing to the right directory on your system, then you’ll be able to run the contents of the demo folder by accessing it as a URL (eg http://localhost:8888/recaptcha-folder/index.php).

It might seem intimidating at this stage, but it’s well worth having a go–let me know if you run into any difficulties!