Actions not working in Photoshop

Since upgrading Photoshop, I have found that the majority of my purchased actions don’t work. Following the steps, it appears to be because photoshop no longer appends copied layer with additional information (e.g. layer 1 copy 1) resulting in the action not being able to find the relevant layer when played.

Can anyone suggest a work around or update their actions to reflect the change in the way photoshop has evolved.

I have tried to install an older version of photoshop where all my actions worked perfectly, but this option doesn’t appear to be available in Creative Cloud (though I have asked Adobe for some guidance).

Any guidance will be gratefully received.

I dont upgrading my Photoshop so can’t currently say a better way from, you can manually change the name of the layer which the action is looking for, if that’s the problem.

See in action on that steps which do not work is it “Layer Via Copy” (Ctrl+J) or “Duplicate Current Layer” command and that should be change, but as said I don’t have the new version so can’t be sure 100%.

Best option is not to upgrade Photoshop every time when it comes out, mostly these are insignificant changes that bring more problems than benefits.

Thank you for your reply.

I’ve installed an older version of photoshop and the majority of my actions are now working. I won’t be upgrading this version and can simply work on the image on the newer version once the action has finished.