Strange font keeps creeping into my Google Chrome. HELP !


#1

Hi !

I am having quite a hard time with google chrome after i installed “Helvetica Neue” font family for design purposes. The font simply crept into all of my browsers ! (Mozilla, ie9, and the latest chrome).

After uninstalling ALL HELVETICA families from my PC (im running windows7), the fonts are back to normal in Firefox and ie9, but not in my Chrome… And i really miss it after trying to adapt to FireFox.

The font rendering is plain bizzare, on most of the websites… Arial is replaced by this weird helveitca Neue that i have successfully uninstalled form my computer, and the sites (even the envato sites) insist on somehow finding it and replacing the default site font.

Help fellow authors :frowning:


#2

Have you tried to restart your PC?


#3
infuse01 said

Have you tried to restart your PC?

Sure i did :slight_smile:


#4

Try deleting your font cache file here:

C:\Windows\System32\FNTCACHE.DAT

and then restart.


#5
freshface said

Try deleting your font cache file here:

C:\Windows\System32\FNTCACHE.DAT

and then restart.

I thought something like this might help, but had no clue about this FNTCACHE.DAT after doing what you said… Nothing changed :frowning:

BUT, i have found a temporary fix for the problem… Installed TaperMonkey for Chrome and downloaded the “Kill Helvetica” script. The pages load the helvetica for a second, then the script forces everything to default. Kind of solved the problem, but id love to know how to revert everything.


#6

I have Helvetica Neue family and Chrome but I have never experienced this issue. However many people experienced this problem and there is a solution you may want to try :wink:

Chrome has some issues when using/displaying text or glyphs in Helvetica.To fix (or rather, work around) this issue; open the custom.css file located in

%USERPROFILE%\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets

and add the following:

@font-face { font-family: ‘helvetica’; src: local(‘Arial’); }

@font-face { font-family: ‘helvetica neue’; src: local(‘Arial’); }

Changes should be immediately applied.


#7
gbs said

I have Helvetica Neue family and Chrome but I have never experienced this issue. However many people experienced this problem and there is a solution you may want to try :wink:

Chrome has some issues when using/displaying text or glyphs in Helvetica.To fix (or rather, work around) this issue; open the custom.css file located in

%USERPROFILE%\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets

and add the following:

@font-face { font-family: ‘helvetica’; src: local(‘Arial’); }

@font-face { font-family: ‘helvetica neue’; src: local(‘Arial’); }

Changes should be immediately applied.

:crying: Won’t work. WHY, not even with a restart ! (BTW, “custom.css” was an empty file)


#8

I have a solution for you, but you won’t like it :reallyevil:


#9
infuse01 said

I have a solution for you, but you won’t like it :reallyevil:

Ahahaha, i think i know you’ll say “get a mac” lolololol


#10
3alisha said
infuse01 said

I have a solution for you, but you won’t like it :reallyevil:

Ahahaha, i think i know you’ll say “get a mac” lolololol

Haha, no I wouldn’t - surprise :smiley:



I would rather recommend to re-format and re-setup your machine. Still not ideal I guess :wink:


#11
infuse01 said
3alisha said
infuse01 said

I have a solution for you, but you won’t like it :reallyevil:

Ahahaha, i think i know you’ll say “get a mac” lolololol

Haha, no I wouldn’t - surprise :smiley:



I would rather recommend to re-format and re-setup your machine. Still not ideal I guess :wink:

Meh, i wont re-format it… Not yet. (waiting for windows8)

Cheers !


#12

Yes the default custom.css is a blank file. Many people reported that method worked so your case is weird. What is your version of Chrome? Did you try uninstall and run the installation again?


#13

I had something similar with fonts on my PC when I had installed some plug-ins.
Reinstall your chrome, at least in my case, it helped. It`s fine now :slight_smile:

cheers


#14

Hi Bro.

Here is some solutions.

Solution 1:
Open Google Chrome and enter this into the address bar

chrome://chrome/settings/fonts

Check to see everything is okay

Solution 2:

Go to my computer or (Computer), Right Click on the white space and click on “Properties”. Then follow the image specially made for you :slight_smile:

http://www.envato.enfusionthemes.com/chrome-font-fix.jpg

Solution 3:
A very simple solution sometimes, “Ctrl + 0” will make the website zoom in or zoom out to normal.

Hope it helps :slight_smile:


#15

The css fix works but the code listed by GBS had incorrect apostrophies. Here is the correct version:

@font-face { font-family: ‘helvetica’; src: local(‘Arial’); }

@font-face { font-family: ‘helvetica neue’; src: local(‘Arial’); }

Blessings :slight_smile:

gbs said

I have Helvetica Neue family and Chrome but I have never experienced this issue. However many people experienced this problem and there is a solution you may want to try :wink:

Chrome has some issues when using/displaying text or glyphs in Helvetica.To fix (or rather, work around) this issue; open the custom.css file located in

%USERPROFILE%\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets

and add the following:

@font-face { font-family: ‘helvetica’; src: local(‘Arial’); }

@font-face { font-family: ‘helvetica neue’; src: local(‘Arial’); }

Changes should be immediately applied.


#16

looks the same to me