Kriesi Enfold theme crashes on php 8 Layer Slider

Hi upgrading organisations website to php8 crashes layerslider with a wp_layerslider_drafts table doesnt exist in error. Has anyone any ideas?

WordPress › Error Fatal error: Uncaught mysqli_sql_exception: Table ‘hblictnh_new.wp_layerslider_drafts’ doesn’t exist in C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\wp-db.php:2056 Stack trace: #0 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\wp-db.php(2056): mysqli_query(Object(mysqli), ‘DESCRIBE wp_lay…’) #1 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\wp-db.php(1945): wpdb->_do_query(‘DESCRIBE wp_lay…’) #2 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\wp-db.php(2695): wpdb->query(‘DESCRIBE wp_lay…’) #3 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-admin\includes\upgrade.php(2749): wpdb->get_results(‘DESCRIBE wp_lay…’) #4 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-content\themes\themeforest-oqSFk1yk-enfold-responsive-multipurpose-theme-wordpress-theme\enfold\config-layerslider\LayerSlider\assets\wp\activation.php(201): dbDelta(Array) #5 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-content\themes\themeforest-oqSFk1yk-enfold-responsive-multipurpose-theme-wordpress-theme\enfold\config-layerslider\LayerSlider\assets\wp\activation.php(86): layerslider_create_db_table() #6 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\class-wp-hook.php(303): layerslider_activation_routine(‘’) #7 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #8 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\plugin.php(470): WP_Hook->do_action(Array) #9 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-settings.php(578): do_action(‘init’) #10 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-config.php(98): require_once(‘C:\inetpub\wwwr…’) #11 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-load.php(50): require_once(‘C:\inetpub\wwwr…’) #12 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-admin\admin.php(34): require_once(‘C:\inetpub\wwwr…’) #13 C:\inetpub\wwwroot\HBLICT_Public_Website\wp-admin\themes.php(10): require_once(‘C:\inetpub\wwwr…’) #14 {main} thrown in C:\inetpub\wwwroot\HBLICT_Public_Website\wp-includes\wp-db.php on line 2056

Hi @cobdeng,

Please contact the author of your purchased theme, the author will assist you.

How to contact an author to get support or for any technical query:

Thanks