(Locked) LayerSlider: old jQuery issue


#1

Got this LayerSlider: old jQuery issue. Installed “jQuery Updater” but still getting the same problem. Please help. email at biznizrich09@yahoo.com for WP login details


#2

Hopefully one of the 2.7 million envato users will know what you want and help you. Good luck


#3

LayerSlider: old jQuery issue
It looks like you are using an old version (1.10.0) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer. If you are using the WordPress version of LayerSlider, you can try out the “jQuery Updater” plugin from the WP plugin depository. If you don’t know what to do, you can write us a private message from our CodeCanyon profile page. We need a temporary WP admin account (or a temporary FTP account in some cases) to solve this issue.

I already followed installing the jQuery Updater but still getting the same. Any response from Code Canyon team so I can give the WP admin details.


#4

Hello from France,

I have the same problem with my Avada theme. I have the message LayerSlider: old jQuery issue
It looks like you are using an old version (1.10.2) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer. If you are using the WordPress version of LayerSlider, you can try out the “jQuery Updater” plugin from the WP plugin depository. If you don’t know what to do, you can write us a private message from our CodeCanyon profile page. We need a temporary WP admin account (or a temporary FTP account in some cases) to solve this issue.

I have already donwloaded and installed the “jQuery Updater” but there are no changes at all.

Did you get an answer ???

Regards.

Dominique


#5

^ This is a result of either your theme or a plugin using their own version of jQuery (which is really bad practice). I’m guessing LayerSlider checks for a minimum jQuery version and the check doesn’t take into account the number 1.10. Easy mistake, but if you’re using WordPress, your site should be using the current default WordPress jQuery version anyway, which is 1.8.3. So whoever’s loading in 1.10 (could be theme, could be another plugin) needs to load in the default WP jQuery instead and your problem will be solved.


#6

It looks like layerSlider is confusing version 1.10 with 1.1 and so, giving you an old version error. The thing is, WP doesn’t include jquery 1.10 by default, so you should ask about this to your theme’s developer (or maybe some other plugin replacing it).



You should disable your other plugins, one-by-one, see what plugin is the one causing this problem. If none of the plugins is, then its most likely the Theme.


#7

This issue is a result of worpdress’ 3.6 release which includes jQuery 1.10. Layer Slider dev guys need to update their plugin and fix their jquery compatibility check to account for 1.10. (mabe remove all decimals, then check version with greaterthan-equalto). F’ed up the devs arent’ replying. Can’t seem to find this jquery check in the code to fix.


#8

It’s not a plugin developers fault, if his plugin does not function with latest jQuery build.


#10

Having the same problem this morning.


#11

old jQuery issue problem solved:

added this snippet to the function.php and it works:

wp_deregister_script( ‘jquery’ );
wp_register_script( ‘jquery’, ‘http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js’, array(), null, in_footer );


#12

My buddy just tried that fix and gets the same thing on his site. I don’t know, maybe he is placing it in the wrong spot.


#13

I did the same at the beginning of the file functions.php included in fiction directory :

<?php if (!isset($content_width)) { $content_width = 1024; } wp_deregister_script('jquery'); wp_register_script('jquery','http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js', array(), null, in_footer ); and for me it works perfectly on Worpress 3.6 and last version of theme fiction Olivier

#14

He got it. He forgot to install the jQuery Updater plugin.


#15
frankiedj said

old jQuery issue problem solved:

added this snippet to the function.php and it works:

wp_deregister_script( ‘jquery’ );
wp_register_script( ‘jquery’, ‘http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js’, array(), null, in_footer );

Unfortunately this is likely to cause future problems with plugins that rely on WordPress’ default jQuery. So the current problem may be solved for now, but you’re way better off just fixing the issue within LayerSlider instead. Should be a fairly easy fix for an experienced developer.


#16

in Javascript “10” > “7” is FALSE, so 10 is less than 7 (compares by character code of the 1st letter)

They should correct it.

Viktor Szépe


#17

Hi I am new to this and I am having the same problem…can anyone help! Please…THX Pete

http://zexueldesires.com/


#18

Install only the plugin


#19
evZek said

Install only the plugin

Yeah that helps for the site…but in my Dashboard I have still the same problem…
Can’t use the slider preview feature in Dashboard.


#20

I can confirm what CallHimX said.

jQuery Updater solve the problem on the homepage but in
LayerSlider’s own interface the problem still exist!


#21

Hello,

I had wordpress 3.5.2 and update to 3.6 and now sends me the following error message:

LayerSlider: old jQuery issue It looks like you are using an old version (1.10.2) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer. If you are using the WordPress version of LayerSlider, you can try out the “jQuery Updater” plugin from the WP plugin depository. If you don’t know what to do, you can write us a private message from our CodeCanyon profile page.

Please Assist!

Kind Regards