Jquery UI 1.12.1 tooltip bug

So as we all know WordPress did another update to 5.6 and as expected is a disaster, this time the jquery-ui tooltip does not work correctly anymore and it is unusable, I have recorded a video to better explain this.

I really hope there is a solution to this.

Thank you.

Can’t you add CSS code to fix the issue?

I tried it is something in the code that is broken, I use the default jquery ui js and css that are added in WordPress as well, this should not happen, the tooltip should work.

If you have any ideas about this please give it a try yourself , you can download the package here including the example that I use here https://jqueryui.com/download/ .

Is either a bug or I am missing something but I don’t think so I tried everythig I could think of, the issue still persists.

Thank you.

This is because the dialog window is absolutely positioned. The tooltip being a child is constrained by the parents width. Try to manually set the min-width property of the tooltip element:

min-width: 500px;

Play with that, see if it helps.

Thank you.

Indeed this is fixing the issue, the only issue that remains if there are just a few words, it looks wired, any thoughts on how to fix this?

I ended up writing my own tooltiop class, waste of time …

The jquery-ui-tooltip worked from almost 15 years and now after this update they messed it up, I really don’t understand the logic behind this…