jquery-1.10.2.min.map 404 Not found on several themes


#1

Hi,
After the 3.6 update as far as I know this error wasn’t appearing. This morning it seemed to start “on my side”. I googled for this and could not find any good answer. I checked the popular files list and apparently all the themes that are using the latest Wordpress and jQuery version have this issue.
I tested the TwentyThirteen theme with no plugins and I get this error too… Does anyone has a good answer on this?
Thanks in advance!


#2

DId you try with some other browser? SOunds to me like the issue comes from your browser (possibly some extensions).


#3

Hummm… It seems to be related with the browser, but not with extensions, because I have just turned them all off. Can you tell me if on your Chrome this theme http://www.pirenko.com/aria_land/ shows any errors?
Once again this error is showing on my browser on more multiple themes and not only on my themes…

Thank you for your feedback :wink:


#4

Nope, no errors here’ latest Chrome.


#5

That link hasn’t that error. It will show only after you open the theme itself, but I assume you did this :wink:
Can you just tell me what browser version and OS?
Thanks once again!


#6

Yep, I know, I opened all of the examples, no above error.

I’m using latest Kubuntu + Chrome Version 28.0.1500.95

EDIT: Just tried on a Windows pc and I get “error” js alert every time I click any of the thumb on your linked landing page.


#7

Everything works…

OS: Win7 Ultimate 64bit + latest Google Chrome


#8

I am on the same setup as Harmonikas996
OS WIN7 Ultimate 64bit + latest Google Chrome and I get this:

Denying load of chrome-extension://kkelicaakdanhinjdeammmilcgefonfh/js/jquery.min.map. Resources must be listed in the web_accessible_resources manifest key in order to be loaded by pages outside the extension.

This shows up on the landing page and on all of the theme pages.


#9

I’m going crazy with Chrome today. It’s flickering even when I’m editing my favorites list on the browser options (when I open and close menus). I have just reinstalled it and it keeps behaving strangely with the same errors as described above.
I’ll see if I can find any valid reason for this…


#10

One thing I just found out: if I “kill” permanently the process Google Chrome Helper the options flicking thing disappears (this was also affecting websites view).
If anyone else is experiencing this please let me know.


#11

Seems to be an official WP 3.6 Bug and according to the ticket below:

http://core.trac.wordpress.org/ticket/24994

The solution would be to remove the 2nd line from “wp-includes/js/jquery/jquery.js”.
Although this is a very nasty practice (editing core files) it seems this will be the solution i the next update based on the issue tracker above.

changing:

/*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license 
//@ sourceMappingURL=jquery-1.10.2.min.map 
*/</pre

to: 

/*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license 
*/

How are you guys solving the issue on your side?


#12

After all I’m not alone :slight_smile:
The weird thing is that I think that this only started yesterday. And it only happens on some Chrome browsers. If you want to turn that off on your browser http://stackoverflow.com/questions/18365315/jquerys-jquery-1-10-2-min-map-is-triggering-a-404-not-found
Anyway, touching any file on the wp-includes is totally forbidden to me.


#13

I guess we will have to wait for 3.6.1


#14

This issue appeared since WP started using jQuery 1.10.2.

This issue does not lie withing WordPress itself, it’s not a WP bug there, but rather in certain plugins calling a jQuery plugin function called jQuery.BlockUI. This function requires jQuery 1.2.3 (or 1.3) in order to work and when the checking happens and matches against 1.10.2, it fails since it would need a leading 0 to make a good comparison like:

1.02.3 < 1.10.2 < 1.2.3

Unfortunately, the only thing that can fix this is making sure all plugins are up to date, particularly the ones that reference this BlockUI function as the newer updated versions of that jQuery plugin have the new comparison model incorporated.


#15
QBKL said

This issue appeared since WP started using jQuery 1.10.2.

This issue does not lie withing WordPress itself, it’s not a WP bug there, but rather in certain plugins calling a jQuery plugin function called jQuery.BlockUI. This function requires jQuery 1.2.3 (or 1.3) in order to work and when the checking happens and matches against 1.10.2, it fails since it would need a leading 0 to make a good comparison like:

1.02.3 < 1.10.2 < 1.2.3

Unfortunately, the only thing that can fix this is making sure all plugins are up to date, particularly the ones that reference this BlockUI function as the newer updated versions of that jQuery plugin have the new comparison model incorporated.

Allow me to disagree... On a fresh Wordpress install with the twenty thirteen theme I have this issue too. No plugins active...

#16
Pirenko said
QBKL said

This issue appeared since WP started using jQuery 1.10.2.

This issue does not lie withing WordPress itself, it’s not a WP bug there, but rather in certain plugins calling a jQuery plugin function called jQuery.BlockUI. This function requires jQuery 1.2.3 (or 1.3) in order to work and when the checking happens and matches against 1.10.2, it fails since it would need a leading 0 to make a good comparison like:

1.02.3 < 1.10.2 < 1.2.3

Unfortunately, the only thing that can fix this is making sure all plugins are up to date, particularly the ones that reference this BlockUI function as the newer updated versions of that jQuery plugin have the new comparison model incorporated.

Allow me to disagree... On a fresh Wordpress install with the twenty thirteen theme I have this issue too. No plugins active...

This error doesn’t appear only in Wordpress. I have it in one of my HTML templates that use JQuery 1.10.2. And it doesn’t load any plugins it’s just the library.


#17

I got rid of this error by going to console “General” settings and disabling “Enable source maps”.
I guess chrome needs an update.


#18

Hm… It’s really strange, previously i don’t get this kind of error, i just get this an hour ago…


#19

As lup said, as a developer you can get rid of this error by disabling “Enable source maps” in Chrome settings.

This error apparently only shows up when using the “DevTools” (Inspect Element etc.) as it’s an “interpretation map” for minified code from what I understand.

This means that any regular user/visitor will never be bothered by this error, provided they won’t use the DevTools, and functionality and usability will not be affected.

Clearly not a WordPress bug, no matter how fresh or old the install is, clean or jam-packed with plugins.


#20

Today I’ve noticed another strange thing.

At the moment, I’m developing few WP themes. I’m using LESS for development (just including less.js) and it seems like Chrome refuses to rerender styles generated by LESS. Basically, I had to add ?ver=<?php echo the_time(); ?> at the end of my styles.less include to see the changes :S Pretty strange. If I remember correctly, Chrome was updated the day before yesterday / yesterday?

Tom