How to properly name the theme functions?

Please suggest what naming convention is good to use? I have read that I should use theme name as prefix, for example for a theme named “abc”, i should use: abc_custom_title();.

Is it acceptable on themeforest? If not, what is better convention?

Yep, that’s necessary!
Always prefix with the theme name. And on top of that:

Definitely prefix your functions. There are many plugins here and on WordPress repository and not everybody prefix their functions, so you might be in the situation when your functions conflict with other functions. So always prefix to prevent that!

Thanks for the reply, I understand I need to prefix but my question was that is the naming convention ok (ie. only the theme prefix) or do I need to make it more unique? For example myusername_themename_functionname();

Your function name should describe itself what it does. As for your example: myusername_themename_functionname();
“myusername” is unneccessary, leave it as “themename_function_name()”.