How to make XAMPP broadcast online?


#1

Hello guys,

I used to use WAMP and it was great except that one day, WordPress stopped working…

So I switched to XAMPP and it’s great also, but I don’t know how to configure it to broadcast the server outside localhost [ useful for when you try to test your site from your laptop or ipad ] . In WAMP it was simple - just right click icon -> Make Online

I get this message when accessing the XAMPP computer by IP

Access forbidden!

New XAMPP security concept:

Access to the requested directory is only available from the local network.

This setting can be configured in the file "httpd-xampp.conf".

If you think this is a server error, please contact the webmaster.

Error 403

192.168.1.117
7/22/2011 12:07:10 AM
Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1

Obviously the address is correct - but there is some htdocs restritctions that occur… and I am not good at htdocs stuff ( any good tuts :smiley: ? ) …

So any suggestions / XAMPP users ?

Thanks!


#2
ZoomIt said

I used to use WAMP and it was great except that one day, WordPress stopped working…

I’m currently using WAMP and running Wordpress on it without a problem. You could do a fresh install of wamp and then install wordpress on it. If it still doesn’t work make sure that you haven’t got Skype running, because if skype is running on my pc, I can’t start wamp.

You’re saying you want to make xampp broadcast online. With online do you mean on the local network, or on the internet? Because they are 2 very different things.


#3

Network…

Anyway, it was the same thing on WAMP…

Yeah, tried freshinstall but no luck :frowning:


#4

see if the option is in http://localhost/security/ otherwise find the httpd-xampp.conf file and post anything that says localhost / 127.0.0.1 / similar


#5

It’s there but there aren’t really any options - http://www.flickr.com/photos/digitalzoomstudio/5962791788/

#
# XAMPP settings
#


    SetEnv MIBDIRS "C:/xampp/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "C:/xampp/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"


#
# PHP-Module setup
#
LoadFile "C:/xampp/php/php5ts.dll"
LoadModule php5_module modules/php5apache2_2.dll


    SetHandler application/x-httpd-php


    SetHandler application/x-httpd-php-source


#
# PHP-CGI setup
#
#
#    SetHandler application/x-httpd-php-cgi
#
#
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#



    PHPINIDir "C:/xampp/php"



    AddType text/html .php .phps


ScriptAlias /php-cgi/ "C:/xampp/php/"

    AllowOverride None
    Options None
    Order deny,allow
    Deny from all
    
        Allow from all
    



    
        SetHandler cgi-script
    
    
        SetHandler None
    



    
    	
    		php_admin_flag safe_mode off
    	
    
    AllowOverride AuthConfig



    Alias /security "C:/xampp/security/htdocs/"
    
        
    		
    			php_admin_flag safe_mode off
    		
        
        AllowOverride AuthConfig
   

    Alias /licenses "C:/xampp/licenses/"
    
        Options +Indexes
        
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        
   

    Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
    
        AllowOverride AuthConfig
    

    Alias /webalizer "C:/xampp/webalizer/"
    
        
    		
    			php_admin_flag safe_mode off
    		
        
        AllowOverride AuthConfig
    


#
# New XAMPP security concept
#

    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/8 
    ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var

EDIT:

Modified it to

#
# XAMPP settings
#


    SetEnv MIBDIRS "C:/xampp/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "C:/xampp/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"


#
# PHP-Module setup
#
LoadFile "C:/xampp/php/php5ts.dll"
LoadModule php5_module modules/php5apache2_2.dll


    SetHandler application/x-httpd-php


    SetHandler application/x-httpd-php-source


#
# PHP-CGI setup
#
#
#    SetHandler application/x-httpd-php-cgi
#
#
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#



    PHPINIDir "C:/xampp/php"



    AddType text/html .php .phps


ScriptAlias /php-cgi/ "C:/xampp/php/"

    AllowOverride None
    Options None
    Order deny,allow
    Deny from all
    
        Allow from all
    



    
        SetHandler cgi-script
    
    
        SetHandler None
    



    
    	
    		php_admin_flag safe_mode off
    	
    
    AllowOverride AuthConfig



    Alias /security "C:/xampp/security/htdocs/"
    
        
    		
    			php_admin_flag safe_mode off
    		
        
        AllowOverride AuthConfig
   

    Alias /licenses "C:/xampp/licenses/"
    
        Options +Indexes
        
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        
   

    Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
    
        AllowOverride AuthConfig
    

    Alias /webalizer "C:/xampp/webalizer/"
    
        
    		
    			php_admin_flag safe_mode off
    		
        
        AllowOverride AuthConfig
    


#
# New XAMPP security concept
#

    Order deny,allow
    Allow from all
    ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var

restarted XAMPP and it worked

Thanks man!


#6

for others with same issue, change:

   Deny from all
    Allow from 127.0.0.0/8 

to

  Allow from all