Flatsome 3.0 menus disappear

Hi. I upgraded to the Flatsome 3.0 theme, which made our menus disappear. I am using standard WooCommerce menus.

I downgraded back to 2.9, and the menus are back.

Any suggestions on how to get menus to work in Flatsome 3.0?

Thanks,
David Shultz

did you solve this problem?

Goto Flatsome -> advanced -> preset and save

Hi. I have not resolved this. I’m not certain how the presets work, and I can’t find any documentation for it. When I select a preset, it asks if I want to import options, and I don’t want to experiment. I’ll wait until this is fixed without my having to do anything with presets.

Hi again. I upgraded to Flatsome 3.0 again and tried to save a Preset, but I’m getting an Error message. All it says is Error!, in green, at the top of the page, so I’m back to 2.9.

If anyone has any suggestions, I would appreciate it.

David

Have the same problem and hope impatiently for a solution as soon as possible.
desta

Hi arecibo2, seems that we two are the only ones having this problem (= Flatsome 3 lets disappear the menu). Or have you solved it?
desta

Hi, desta. I solved it by starting a new menu totally from scratch. The new UX builder is a little quirky, and there is a bit of a learning curve to it, but I was able to create a nicer menu than I had before.

So, I’m unhappy that the theme makers did not acknowledge the problem or fix it, but I’m happy with the end result.

You can see the results here: http://homeandaway.gallery/

Best of luck,
David

Hello arecibo2,
thank you very much for your answer. I tried to proceed as you did, but I did not succeed. There were more problems than only the disappeared start menu: No top menu, broken UX banners and the product category menu on the right side instead of the left, product description below instead of beside the product menu. Now I give up. Hope that there will fix the problems sometime in the future…
Your site is really nice and the objects you sell, are very interesting for someone who lives in Germany like me.

I’m sorry to hear it, Desta. I tried a different theme because of this problem, but I came back to Flatsome because I still like it better.

Thank you for the kind words about our website.

David

I had this issue after upgrading from Flastome 2.9.9 > 3.9, I solved the issue & got the menu back by disabling the child theme & just using the new version of Flatsome (I had no customisations)

Old Topic