Element Pack Causes Elementor WordPress Plugin Not to Function


I’m posting this through the forum because there doesn’t seem to be a real help center to respond to my question.

I just bought the Element Pack (CodeCanyon) containing WordPress Elementor widgets. Once I installed it, the Elementor WordPress plugin no longer fully loads and I can no longer access the functionality.

To troubleshoot, I deactivated, deleted, and reinstalled the Elementor, Elementor Pro, and Element Pack plug ins. I then activated Elementor and Elementor Pro. Because the plug ins were working fine before the upload of the new Element Pack plug in.

Indeed, Elementor worked just fine. But as soon as I activated Element Pack, I got the dreaded “loading” icon (light blue arrow that circles like a clock) on the Elementor panel on the left. It just never finishes loading.

I tried this a few times, each time having the same result. I really want to use 3 of the widgets from the Element Pack so that I can do hovers and drop boxes. Any suggestions on what I can do?

Oh, there were updates to Elementor and Element Pack, which I installed to ensure that everything was up to date. I’m stalled out and am waiting for feedback before I can move forward.

Thanks, Dianne

Hello Dianne!

The developer who created this plugin offers support for this item, all you have to do is to open a ticket on his support website: BdThemes Support

If you already created a support ticket, most probably the author will reply soon (some authors are from countries where right now there are public holidays, so there might be a small delay)