Can't upload my files to WP.ORG!!!

wordpress
themeforest

#1

Hi there. I am new to all of this stuff and am trying to work it out. I recently bought a ThemeForest Theme to upload into my WordPress.org but the files will not load.
I have hosting and have DNS going to NS1.WORDPRESS.ORG. Is this right?
I have downlloaded the ThemeForest files for my theme and there are 3 zip files, but none of these will load?
Getting frustrated now. If anyone can help me using lay mans language I would really appreciate it.


#2

You need hosting service for the themes at ThemeForest. You cannot upload the theme to WordPress.ORG

https://en.support.wordpress.com/themes/adding-new-themes/ .

If you need support, feel free to drop me an email. I can help you on choosing the hosting service and managing the DNS as well


#3

Thanks Ki-themes. I do have hosting from 1stdomains and it is directing to my domain name. But when I try to load the theme from my WP-admin it just stalls! I am not really sure what file to download.


#4

I have no idea. Only thing I could offer is a paid support (Fix bug) at Studio, if you’re interested in


#5

If I understand you correctly your domain name is registered on wordpress.org but your hosting is on another server?

If so then you need to connect these two, here is a video where you can see these steps.

But if your website is hosted on wordpress.org then you will not be able to upload any theme from themeforest only the themes from wordpress repository.


#6

Thanks. I have changed the Nameservers to direct to my site. The problem is uploading the actual ThemeForest theme zip files. I think they are too big. I will try to submit a ticket for assistance!
Thanks again for your input.