can not login to

I have had an elements plan for quit a while, but it no longer works. If I login i get a “Envato Elements is temporarily unavailable. We’re working on getting it fixed.” Message, but the site is live and not listed as having issues.

I can load the content in a incognito window, but when i try to use my login info the site stops loading and gives me the error message.

I’ve tried writing support, and have gotten no answers. I tried to renew my subscription and the same thing happens. I can purchase things in the envato market, which i just did, same login, same payment details. But i can not use the Elements.


Screen Shot 2022-11-28 at 12.10.39

Hi @destacachile,

Please contact Elements Support. Elements Support Team will be happy to help.


thank you, i will try again. but i have not received any answers on this subject.

I am also seeing the same error. One of my friend in Europe is also having the same issue and message on the site. No update on status page.

well, low an behold my elements subscription purchase had expired, i received no notifications about this, or that there was a problem with the subscription. my account kept working and i kept downloading. so my account was blocked. now trying to renew the service i open a ticket to find out why it’s just me that can’t access the site, and they blocked my Themeforest account where I had just purchased templates that I have not used. Now i need to access a purchase code for something i paid for, and cannot because Elements decided that their error, is my problem. it’s not my fault the system didn’t notify me of a subscription renewal, and especially not my fault I was able to keep downloading with no active subscription. i have received no assistance either than informing me a transaction in August 2022 did not go through.

I have the same issue with the same screen popping up, I am trying to renew my service but I can’t

get past this screen

Please help

Yeah this has been going on for so long and for so many people. Support always says to submit a ticket, but obviously it’s a big issue for everyone! It happens for me all the time using both Chrome and Firefox to log in. It will work in private browsing mode only which is a hassle.

I cant even get it to work in private mode