php 8.1


My wordpress website with Bridge Themen doesnt run on PHP 8.1 only on PHP 7.4.

How can I fix this?

Its the Bridge Core plugin thats a problem. I do need this plugin.

Anybody an idea?



Are you definitely using the latest copy of the theme?

Changelog says its compatible to 8.2 Bridge Documentation and Tutorials | Changelog

1 Like

Update the theme and plugins.


ĂŤ got recommed not to automatically update the theme and probably missed some updates. From were can I update all the relevant updates for Bridge Core (witch seems te be the problem with the PHP version 8.1)?

Create a staging website ( copy/clone ) and update everything there first. If there’s no problem, you can perform an update on the live website as well.

Updating the plugin only may cause issues with the theme features/functions, too. You should update them both. For more information, you can contact the item author for support.

Hi Ki-themes,

Did all this (newest version, all the updates), but doesn’t work. The Bridge core plugin is the troublemaker.

Dont understand. Do you?

Hi Charlie,

Yes all the new updates and Bridge 26.9 version, but still not running on PHP 8.1.

Its the Bridge Core plugin thats the troublemaker.

Do you have any suggestions?

Change it to PHP 8.2, PHP 8.1 is(may) not (be) supported

VERSION 29.6 – JUNE 13TH, 2023

– Added PHP 8.2 compatibility

Tried PHP 8.2 same problem…

Really dont understand…

Contact your hosting provider. Maybe one of the extension is not enabled.

Contacting your hosting provider will be a good first step. They should be able track down any specific errors, which will be tremendously helpful. Then, if you’re still unable to get it working, send those error details to the author:

Hi All,

I get these logs of plugins in the theme that make errors:

twitter-api.php on line 91
[Tue Jun 20 10:11:17.869707 2023] [fcgid:warn] [pid 16357:tid 140289930913536] [client] mod_fcgid: stderr: PHP Fatal error: Unparenthesized a ? b : c ? d : e is not supported. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in /var/www/vhosts/ on line 1912

Its the revslider and the twitter parts of a plugin or theme.

The host says its plugins from the forrest Bridge theme.

How can I contact the author? Does anybody know?

Depending on your support status you can check options her

That particular error is coming from the Revolution Slider plugin. Make sure that when you update the theme, you also update the plugins that come with it. The author has a full tutorial for this here:

1 Like


I deactivated Rev Slider and Twitter (who needs twitter anyway) and the problem got solved!

No I can run my website on PHP 8.1