Error Warning: preg_match()??


#1

IT appeared in My page< what is this?

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 205

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 204

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 205

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 204

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 205

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 204

Warning: preg_match() [function.preg-match]: Compilation failed: nothing to repeat at offset 1 in /home/storage/9/7b/64/ositio1/public_html/wp-includes/class-wp.php on line 205


#2

all my pages have this problem… http://ositio.com.br/o-sitio


#3

I’ve seen that the error appears on pages, not on the homepage.

This means that the permalinks structure is somehow corrupted (most probably you are using now custom permalinks). To fix it back:

step 0: if possible, backup your WP installation folder.
step 1: temporary disable all the plugins (important step)

step 2: in WordPress admin dashboard, go to Settings -> Permalinks

step 3: remember or note down somewhere what you have in the custom permalinks field: http://awesomescreenshot.com/0534epzk0c

step 4: temporary enable (switch to) the default permalink: http://awesomescreenshot.com/0f74epyi15 Click Save Changes button.

step 5: verify the website is working now (not everything, because the plugins are disabled, but the preg_match error should be gone)

step 6: switch back to the custom permalinks setting you had at step 3

step 7: enable back all the plugins

The error should be gone.


#4

Yeah! Tks
you help me a lot.

Hugs

Zee