Cant activate Envato Market Plugin OAuth Personal Token

I downloaded and installed Envato Market Plugin ok. I click the link to generate the API personal token and all goes ok (I made sure the proper permissions enabled). All looks ok but when I click on ‘save changes’ or ‘test API connection’ I get the following error: “The OAuth Personal Token could not be verified. Please check that the Token has been entered correctly and has the minimum required permissions.”. Any advice appreciated. I have contacted envato market plugin support and no response.

I updated market plugin with update which appeared today. Still fails but more failure information. I addition to failure above I now also receive " Additional Error Details:
Failed to query total number of items in API response.
Forbidden"

Hi

You can try with creating a new token with all required permissions.

Thanks

1 Like

Getting a “forbidden” error here suggests you might have created an app rather than a personal token, or you copied and pasted the token into the plugin incorrectly. Did you use the link given to you by the plugin? https://build.envato.com/create-token/?purchase:list=t&purchase:download=t

The token should look like this: To2tQtLghGgWEuL71iqRincmeGfrGlie

Make sure when you copy and paste it that you copy it completely. It should be 32 characters long in total.

3 Likes

Thanks for response. I tried >10 times, including with all permissions enabled. Identical error every time.

And, yes, I used the link and copied/pasted carefully and yes was 32 characters.

screenshots removed because of personal token.

Hi

Before you create a new token the following permission should be selected from the list of permission available on the Token page.

  1. View and search Envato sites (checked by default)
  2. View the user’s Envato account username
  3. View the user’s email address
  4. View the user’s account profile details
  5. Download the user’s purchased items
  6. Verify purchases of the user’s item
  7. List purchases the user has made

Otherwise please open Help ticket and let them know. They will be happy to assist you.

Thanks

Hi. Thanks for response. I tried selecting ALL permissions - above and others. I also opened ticket with envato general help who sent me to envato market plugin support where I also opened ticket – no response in 5 days.

Yeah, the error in question isn’t related to permissions at all actually. If you created a token, that endpoint will work even with all permissions unchecked, so there’s something else going on here.

I’d guess it’s something like your server’s IP being blocked, but that’s pretty improbable, or at least it should be. Would you possibly have another server or local install you could test it on?

Other than that, you’ll need to wait on a response from support for this one unfortunately. Last I checked, the dev behind that plugin was travelling so he may need a couple more days to get back to you.

2 Likes

Thanks for response. Blocked IP is possible. I recently added the sitelock service to avoide blacklist by google ads & a few services stopped working (calendar sync to airbnb and vrbo for example). I had to white-list several IP ranges and user agents to get through. Any idea where I could get IP address/range or other info to whitelist on my firewall?

Sorry, I meant a block from their end. The fact that you’re getting a Forbidden error suggests that your server is in fact connecting to the API without trouble, but the API is for some reason rejecting your server.

That said, it’s not impossible that a firewall on your server could also return a Forbidden error, but it is extremely rare especially for a server. You can try whitelisting 104.18.252.82 to see if it helps.

I tried white-listing the ip above. No change.

1 Like

Hi @davesliter,

I’ve located your support ticket and replied with some troubleshooting steps to take. Let’s take the discussion over there and we’ll get the issue sorted out.

2 Likes

I had the same issue, only to notice that I had created an app not a token. It is all fine now.

mesmo problema aguardando retorno do suporte

https://build.envato.com/create-token/ this is the right link.

If you go from the link of WP Envato markt it will take you to app token which is something else, I was too wasting my time on it , how stupid from them
Cheers