Avada Translation Files

wordpress
cms
#1

Hi,

I want to translate a blog button which says “Read more” in my own language. After making a lot of changes the text still doesn’t change. We use Fusion Builder to build up the blog. Does anybody know what is going wrong? I’ll explain here:

After downloading the po & mo files for the Avada theme, Fusion Builder and Fusion Core on Github

  1. I have put them in the following directories:
    Avada: wp-content/languages/themes (not the child-theme, but the original)
    I put it also in wp-content/themes/Avada/languages, but this is the wrong path.
    Fusion Builder: wp-content/plugins/fusion-builder/languages
    I put it also in wp-content/plugins/fusion-builder/languages but this is the wrong path.
    Fusion Core: wp-content/languages/plugins
    I put it also in wp-content/plugins/fusion-core/languages but this is the wrong path.

In the directories there’s already a pot file. So you have 3 different files.

  1. In the root there’s a file called wp_config.php
    I’ve added a rule define (‘WPLANG’, ‘nl_NL’). The filenames also end with nl_NL.ext (po or mo)

This should work, but there’s a workaround:

  1. Add code to the file functions.php (public_html/wp_includes)
    This code can be found on codex.wordpress.org
    "Modify The Read More Link Text"

    function modify_read_more_link() {
    return ‘Your Read More Link Text’;
    }
    add_filter( ‘the_content_more_link’, ‘modify_read_more_link’ );

Still I don’t know if the last one customizes the editor in the cms if you add a <-- more text -->

#2

Hi @VincentWiwi,

Welcome to the forums! Have you checked Avada theme documentation? Translation process may already be described there. In case of further questions consider contacting theme support:

Thanks,
Luca

2 Likes
#3

Yes, I have checked Avada Theme Documentation. Followed every step, but it makes no difference.
I have installed a plugin Gettext override translations with the correct override text and it worked.

Also in Avada Documents there has made an error about “Updating The Translations Catalogue

#4

Hello, @VincentWiwi

Have you tried to reach out to Avada theme author for support? If not, please use following section:

Thanks

#5

I’m not sure if you already found a solution, but if you did, I’m still going to answer this, because a lot of people might stumble upon this.

In my case, “Read more” was not present in my language PO file. Adding it DID NOT HELP. After I did, the text underneath a blogpost would still say “Read more”. I discovered you have to compile the PO file to a MO file. This can be done with numerous online tools like https://po2mo.net/.

After uploading the MO file to the right directory, the text should now say “Read More” in your own language. In my case “Lees meer” (Dutch). Notice the type the OP made in his list of paths, the right path for Fusion Builder is the same as Fusion Core and should be wp-content/languages/plugins.

Best of luck!
Jon

#6

Hello Jon,

I have the exact problem.

I add “Read more” in my po file:

#: wp-content/plugins/fusion-builder/shortcodes/fusion-blog.php:1447
msgid “Read More”
msgstr “Lees Meer”

compile mo file but nothing happens.

Po and mo file I changed in wp-content/languages folder.

Maybe I not understand this part “Notice the type the OP made in his list of paths, the right path for Fusion Builder is the same as Fusion Core and should be wp-content/languages/plugins”.

Thanks in advance
Stanley

1 Like
#7

Hi! I have the same problem. I translate my whole website but “Read more”. I tried with .mo and .po files. I tried to modify functions.php as this instructions: https://theme-fusion.com/documentation/avada/how-to/how-to-change-to-read-more-on-blog-excerpt/ but there’s no change. How can I translate “read more” in the blog section?
Thanks for your time

#8

I can do it for you for free, PM me

#9

Hi Elpakk, thanks to answer me. Can you tell me how to translate avada files, please?
I have an issue at this url https://consulentesicurezzaalimentare.it/blog/
I can’t translate “read more”, “by”, “8th”, “categories” and “comments” at the bottom of the post. Other pages are well translated

#10

Hi again, I’ve done, I appreciate your help offer, have a nice day.

#11

Hola, lo que a mi me ayudó a resolverlo fue instalar Loco Translate y traducir el plugin Fusion Builder. Antes había intentado traducir la frase Read More desde el template y no funcionó, pero cuando lo hice desde el plugin sí.
Espero haber ayudado!