regarding theme uploading..

when i upload the theme in wordpress it says …the link you are trying to reach is expired…my theme is ’ traveler '.please suggest the solution asap.


The “link you followed has expired” message appears when your server rejects the uploaded file, usually because it was too large, or your web server ran out of memory. Here are some different ways you can fix the error and install your theme:

1. Verify that you are uploading the correct file

When downloading your theme or plugin from the downloads page, you will be presented with multiple options. Be sure to select the “Installable WordPress file only” version and upload that file into WordPress.

If you do not see this option, then you may have purchased an item which is not compatible with WordPress. I would suggest that you contact the author of the item you purchased to see if they offer a WordPress version and can help you exchange it.

2. Install with the Envato Market plugin

Envato Market now has an official WordPress plugin which can install your themes and plugins in a single click. If you are not experienced with FTP, this is the easiest and fastest way to get your purchases running.

  1. Download the plugin from:
  2. Upload and activate the plugin on your website.
  3. Click “Envato Market” in the WordPress sidebar.
  4. Under “Global OAuth Personal Token,” click the “generate a personal token” link.
    • You may be prompted to sign in with your Envato Market account.
    • Do not uncheck any of the checked options, the proper permissions have been chosen for you.
  5. Scroll down and check the box that you have read and agree to the terms.
  6. Click the “create token” button and copy the code.
  7. Return to the plugin page on your WordPress dashboard, paste the code, and click save.

If you see a blank page or internal server error when installing a theme through this plugin, then contact your web host. There is likely a memory limit being hit and they will need to increase it.

3. Upload manually with FTP or cPanel

If your web host uses cPanel or you have experience with FTP, you can upload the theme manually. The official WordPress website has instructions for both of these methods:

4. Contact your web host

Your web host will need to determine what part of the install process is being limited and increase the limit so that you can install the theme through the WordPress dashboard. Contact their support and let them know you are having problems uploading the theme. Be sure to tell them the size of the file you are trying to upload.

If you have access to server settings or are working on a local server, you can try changing some PHP options yourself in the php.ini file:

  • Set both post_max_size and upload_max_filesize to be larger than the theme file.
  • Ensure memory_limit is generous (at least 128M is recommended).


1 Like

i have uploaded the theme successfully but i cant see the theme on my website…it shows blank like user’s blog on wordpress…i have activated the theme

WP themes don’t look like the demo until you have installed demo (or your own) content.

Check documentation which will talk about this

1 Like

i have installed the demo…the theme is on background but the default webpage of the wordpress (BLOG…Hello world…welcome to the wordpress)

this page does not went off after uploading all the required plugins

Assuming all the pages imported etc (bear in mind that the theme will almost certainly not include the images from the demo) then is the front page set to the right page? (The image above doesn’t look like the correct Home page is assigned)

1 Like

yes theme is uploaded but the site showing this…very annoying how can i remove and get access over the theme…plz help me out

You can remove the theme in under appearance > themes BUT it looks like you have not set the home or the blog page properly - settings > reading > front page etc.

this is how my dashboard looks like.

and this is my web page looks like …i have uploaded all the required plugins…

Check the documentation which will guide you through installing not only the plugins but demo content and activating the theme.

Once all the demo content (not just the plugins) are installed then you set the front page to be the right page

Otherwise you can hire help to set it up at

1 Like

can anyone help me with this i have uploaded the theme,required pliugins,install demo,everything according to the documentation…but i cant see,have access to the theme…i only see this…please help me regarding the asap…


may be you didn’t set everything as like menu settings, front page settings and theme options necessary settings. Please check and go with documentation to finish the necessary settings.


1 Like

yes i went through the documentation step by step the the theme is uploaded it is showing on the dashboard…when i go to customize or edit the i wont let showing the default wordpress pare as users blog…i have installed the install demo also and all the required plugins.


The best thing will be please contact theme Author and let them know How to Contact your purchased theme Author, theme author will be happy to assist you.