i purchased Tour Booking - Tour Adventure WordPress Theme - Entrada by paying $65. Downloaded all the files. But when i try to install on my wordpress, it is saying, "The link you followed has expired". So can't really install it. What is the problem?

#1

i purchased Tour Booking - Tour Adventure WordPress Theme - Entrada by paying $65. Downloaded all the files. But when i try to install on my wordpress, it is saying, “The link you followed has expired”. So can’t really install it. What is the problem?

#2

Hello!

This error appears when your server rejects the uploaded file, usually because it was too large, or your web server ran out of memory. Here are some different ways you can fix the error and install your theme:

1. Verify that you are uploading the correct file

When downloading your theme from the downloads page, you will be presented with multiple options. Be sure to select the “Installable WordPress file only” version and upload that file into WordPress.

If you do not see this option, then you may have purchased an item which is not compatible with WordPress. I would suggest that you contact the author of the item you purchased to see if they offer a WordPress version and can help you exchange it.

2. Install with the Envato Market plugin

Envato Market now has an official WordPress plugin which can install your themes in a single click. If you are not experienced with FTP, this is the easiest and fastest way to get your theme running.

  1. Download the plugin from: http://envato.github.io/wp-envato-market/
  2. Upload and activate the plugin on your website.
  3. Click “Envato Market” in the WordPress sidebar.
  4. Under “Global OAuth Personal Token,” click the “generate a personal token” link.
    • You may be prompted to sign in with your Envato Market account.
    • Do not uncheck any of the checked options, the proper permissions have been chosen for you.
  5. Scroll down and check the box that you have read and agree to the terms.
  6. Click the “create token” button and copy the code.
  7. Return to the plugin page on your WordPress dashboard, paste the code, and click save.

If you see a blank page or internal server error when installing a theme through this plugin, then contact your web host. There is likely a memory limit being hit and they will need to increase it.

3. Upload manually with FTP or cPanel

If your web host uses cPanel or you have experience with FTP, you can upload the theme manually. The official WordPress website has instructions for both of these methods:

https://codex.wordpress.org/Using_Themes#Adding_New_Themes

4. Contact your web host

Your web host will need to determine what part of the install process is being limited and increase the limit so that you can install the theme through the WordPress dashboard. Contact their support and let them know you are having problems uploading the theme. Be sure to tell them the size of the file you are trying to upload.

If you have access to server settings or are working on a local server, you can try changing some PHP options yourself in the php.ini file:

  • Set both post_max_size and upload_max_filesize to be larger than the theme file.
  • Ensure memory_limit is generous (at least 128M is recommended).

Thanks!

1 Like
#3

can’t able to install, and right now, not even hosted the site. Just using offline in localhost.

#4

Please check that you are using latest version php (php 7.x) or at least 5.6 and have enough value for the following php settings:
upload_max_size
post_max_size
max_execution_time

also the bottom of your wp-config.php file you have assigned:

define('WP_MEMORY_LIMIT', '256M');

Thanks

#5

how do i upgrade my php. My current version is 5.5.12.
thanks

#6

please contact your hosting support. They will assist you about this concern. Thanks

#7

Hi
Be sure that you are installing only wordpress theme, not all files as zip

Also disable all plugins if you have others installed.

Cheers

1 Like
#8

Add this into your .htaccess

php_value upload_max_filesize 64M

php_value post_max_size 64M
php_value max_execution_time 300
php_value max_input_time 300

Will work after… or speak to your host to change max size to bigger one.

Good luck

1 Like