How to accents in xml files


#1

I am using the oxylus scrolling menu and the text is to be edited in the xml file but I cannot add accents no matter what I try.
I sent them an email but then I found out they prefer that we should use the forum. Any help from anywhere will be appreciated.
here is what I tried
<item label="Alternative pour la présentation…
and this
<item label="Alternative pour la présentation…
and this
<item label="Alternative pour la présentation…

none of these worked.
Thanks in advance
Mireille


#2

I’m not exactly sure what file you are talking about, nor have I attempted this to see if it works… but it sounds like the accent character of the font you are using is not embedded in the file. If the textfield that contains the text you are trying to input into is an object in your .fla, select the text field and choose the ‘embed’ options in the properties panel. Select to embed all characters, and see if that works for you… you may also have to try using a different font if the font you are using does not contain that accent character.

If the textfield is created via ActionScipt double check that the font is embedded in you library… and that the font you are using contains the accent character.


#3

if you want to use special characters in .xml files you have to write their ascii code. If you just put é it will not work. Instead of é, use � and so on… You have a good ascii table here : http://www.asciitable.com/ . And the second thing is what Joe said. Always embed your fonts, and embed the special characters you are using too. So if you use an ‘é’ embed it.
Good luck :wink:


#4

my last comment was not encoded properly :smiley: instead of ‘é’ use & # 130; (without spaces between)


#5

Thank you for the replies.
I have tried that to no avail. It is so frustrating that I am considering not buying xml files any more. I would rather edit the fla that mess with xml.
Mireille


#6

You could use a program like Word, look into the symbols and convert with your calculator the character code (hex value) to decimal. Actually, at the bottom of the symbol window there is a from: option that you can choose ASCII (decimal). In that way skip the calculator.

for example:
á = & # 225; – Without spaces
é = & # 223;


#7

mmm, I have exactly the same problem.

I’m trying to write Ñ and í with no results using ASCII…

If it is too complex make a change so simple maybe .xml ain’t a good idea…


#8

mmm, I have exactly the same problem.

I’m trying to write Ñ and í with no results using ASCII…

If it is too complex make a change so simple maybe .xml ain’t a good idea…


#9

mireillegreen,

Embed the characters you need in your dynamic text.
Open your fla file and in the properties of your dynamic text box click the Character Embedding button.

For French characters paste this:

â? ? ùæçéèêëîïôœùûü«»ÜÛÙŒÔÏÎËÊÈÉÇÆÄÂÀ

That should fix your problem.


#10

I had many (many) problems with latin characters and parsing xml in flash. I developed for my projects a “encoder-decoder” to solve them. Finally i uploaded a file here, maybe could be useful for the problem you are commenting.