Expired link notice during install

Get the following error u[pon installation:

The link you followed has expired. Please try again.

Hi,

Thanks for asking your question at Envato Forum.

nothing showing in your link?

How to contact any Item Author from Here

If they ask about purchase key then collect from Here

Still have any question open a Envato help ticket from Here

Thanks

Hello!

This error appears when your server rejects the uploaded file, usually because it was too large, or your web server ran out of memory. Here are some different ways you can fix the error and install your theme:

1. Verify that you are uploading the correct file

When downloading your theme from the downloads page, you will be presented with multiple options. Be sure to select the “Installable WordPress file only” version and upload that file into WordPress.

If you do not see this option, then you may have purchased an item which is not compatible with WordPress. I would suggest that you contact the author of the item you purchased to see if they offer a WordPress version and can help you exchange it.

2. Install with the Envato Market plugin

Envato Market now has an official WordPress plugin which can install your themes in a single click. If you are not experienced with FTP, this is the easiest and fastest way to get your theme running.

  1. Download the plugin from: http://envato.github.io/wp-envato-market/
  2. Upload and activate the plugin on your website.
  3. Click “Envato Market” in the WordPress sidebar.
  4. Under “Global OAuth Personal Token,” click the “generate a personal token” link.
    • You may be prompted to sign in with your Envato Market account.
    • Do not uncheck any of the checked options, the proper permissions have been chosen for you.
  5. Scroll down and check the box that you have read and agree to the terms.
  6. Click the “create token” button and copy the code.
  7. Return to the plugin page on your WordPress dashboard, paste the code, and click save.

If you see a blank page or internal server error when installing a theme through this plugin, then contact your web host. There is likely a memory limit being hit and they will need to increase it.

3. Upload manually with FTP or cPanel

If your web host uses cPanel or you have experience with FTP, you can upload the theme manually. The official WordPress website has instructions for both of these methods:

https://codex.wordpress.org/Using_Themes#Adding_New_Themes

4. Contact your web host

Your web host will need to determine what part of the install process is being limited and increase the limit so that you can install the theme through the WordPress dashboard. Contact their support and let them know you are having problems uploading the theme. Be sure to tell them the size of the file you are trying to upload.

If you have access to server settings or are working on a local server, you can try changing some PHP options yourself in the php.ini file:

  • Set both post_max_size and upload_max_filesize to be larger than the theme file.
  • Ensure memory_limit is generous (at least 128M is recommended).

Thanks!

2 Likes

Hi,

Please follow @baileyherbert reply and I hope you can fix. In short if you put the following code into wp-config.php will fix your issues(as I guess):

define(‘WP_MEMORY_LIMIT’, ‘256M’);

Thanks

Just changed we will see

Thx but it did not work

21%20AM

May be syntax error: single quote (’) doing problem. if you check your screenshots you will see difference.
So, please copy from your wp-config.php
define(‘WP_DEBUG’, ‘false’);

Paste and replace:
WP_DEBUG to WP_MEMORY_LIMIT
and
false to 256M

Hope it will work.

Thanks

removing the single quotes crashed the site so I put the single quotes back in

Hi @lillythomas

I didn’t mentioned to remove single quote. I mean they are not same as looking
please check your screenshot

Thanks

still says link expired

please check still your screenshots single quote symbol is not same. delete single quote and insert from your php editor.

fixed that but it still does not work something must be outdated on authors side; this is the first and only theme I have not been able to install thx for your help

This is not a theme issue. Please check that you went through all of the suggestions in my post - changing the memory limit was just one of the three different steps.

Ultimately, if you can’t figure it out, you need to contact your web host. It’s an issue on their side.

1 Like

AS you can see spoke with godaddy support memory has been upgraded still a nogo

What about this?

image

This means if the theme is larger than 32 MB then you’ll get the “link has expired” error.


zip file will not fully extract when manually uploaded to folder in instructions

will try in dashboard but it is not extracting after manually placing on godaddy site

I believe the expired link message is because the folder wont extract properly. It is still giving expired link error

The zip file was corrupted I opened it on my computer then rearchived it and manually placed it in the folder and reextracted it and then it worked. But it turned out to be the wrong theme I wanted the gadget review theme

I am good to go now imported demo thanks for all your help

Ahh, so that was the issue. Your file is 33 MB and the upload limit was 32 (amazingly close!)

Want to give it another try by uploading it into the WordPress dashboard?