WP4.5 Error from plugin

wordpress

#1

is deprecated since version 4.5! Use wp_get_current_user() instead … this notice I got from theme. Will reviewer soft reject this or not ? I don’t know when user will update plugin.

I can add that “plugin is compatibile with Your version of WordPress” on plugins page.