WP - Slider Revolution vs WooCommerce plugin compability Which one

I am experiencing some challenges. These plugins (slider revolution and woocommerce) are incompatible. When both are activated it causes server error 500. What seems to be the problem? Also, when i try to customize depot theme i get this error - There has been a critical error on your website. Please check your site admin email inbox for instructions. any help?

Each item has a “support” tab at the top of its Details page on the marketplaces. Some authors have a simple contact form, others have entire support forums, so this tab will guide you to the proper place.

The “500 Internal Server Error” page you’re seeing means the Website is causing a fatal error. Usually, this can caused by an outdated version of PHP, but it could be potentially something else.

Before contacting the author of the Item, you should contact your web host to get some useful details:

  • Ask them for the exact error message causing the website to fail.
  • Also ask them to ensure your website is running PHP 7 or newer.

If hosting provider let you know that error is coming from the Website script then Contact your purchased Item Author. Contact Author and let them know.

Thanks!