WordPress theme soft reject

Hello, can I have your help with this?

  1. Ensure all widgets are adequately styled and display correctly. Example(s): https://envato.d.pr/CMNLH2

What’s the issue with calendar?


Maybe, but maybe - the background should be transparent (white). I am not sure about this but I had similar soft rejections because of background color of select box (it was white but the background of widget area by default was black).

And the second one (which may be real reason) - it looks like the numbers are not the same size or alignment is wrong - it looks like they are up/down. The numbers 6 and 8 looks like they are pushed more up (maybe I am wrong - I wear glasses :eyeglasses:)


First color was black, wasn’t ok, so I made transparent with line and color black… Not ok…

Size is the same for numbers but I will check again, maybe to make other typo font.

All boxes are center, number in box are center.

In my opinion this is not fair for soft reject but… This is it… No problem and no complain regarding this.

Again Thanks

Ps. If you have your theme can you send printscreen with your calendar?

Use the default WordPress theme (Twenty Twenty) and check there - that is the best place to check how it should looks like.

I really don’t see anything else what you could change.

Yes, this was as default and say that need to fix…


I think the Calendar widget are not styled the same way as you have done in your theme. All widgets should styled the same as like widget title, fonts, color, spacing and alignment.

1 Like

I think you should apply background color only to ‘M’, ‘T’, ‘W’ … and the numbers…
There is no need to apply background color to the table footer (Jan).

Hi, thanks

I think this is fixed…
One question, we use redux options, so our option to choose footer columns, 1-2-3-4 is from here.

As default reviewer wants footer to be hidden, ok, this is made.
Now he tell me that when add widget in footer is not shown,
yes is hidden because footer is hidden from theme options, need to install redux and to enable it.

Is not ok like this?
To tell him this? That need to install and enable redux plugin?


By default there should be nothing in the footer but if you add a widgets the widgets must show up there without installing any additional plugins.

In other words, you must have some “default layout” for footer widgets.

1 Like

I agree with @CocoBasic

The best way to handle this is, when there is no widgets added the footer should have a default layout and if there is any widget added then footer should display widgets without enabling them.

Is ok, i fix those.

Can i have other help from you?

Now reviewer sais to fi this, i use escaping in my theme but this rows i don’t undersand how need to be escaped:

					<div id="mySidenav" class="sidenav">
						<a href="javascript:void(0)" class="closebtn" onclick="closeNav()">&times;</a>
						<div class="sp-module">
						<?php musiziya_main_nav(); ?>

I use this to have on responsive my sidebar menu.

2.This is also plugin-territory:
Here i have options for header to show social icons with links, here i need to make plugin for this part, yes?