WordPress Importer notices/strict standards

wordpress

#1

Hey, we include the WordPress importer (v0.6.1) in our theme/plugin, so our customers can easily import the dummy content. While it works well, we get notices/strict standards reports, which might be a reason for a soft reject from the Envato reviewing staff:
Strict Standards: Redefining already defined constructor for class WXR_Parser_Regex Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) Notice: wp_get_http is deprecated since version 4.4! Use WP_Http instead.
Did any of you modify the files or do you leave them as they are? If you do have a fixed version, would you please share the solution?

Thank you :slight_smile:


#2

The same issue was raised here

wordpress.org/support/topic/notice-wp_get_http-is-deprecated-since-version-44.

and here

Unfortunately no solution is available. Can anyone help?

(Note: This might help you pass the reviewer https://core.trac.wordpress.org/ticket/34679 )


#3

Thank you for your response. We did not see the ticket on core.trac.wordpress.org, will paste the link for the reviewer :slight_smile: thank you!


#4

what’s new about that? what about reviewer?


#5

Hey, in the Comments we wrote:

Please note that if you receive any notices or strict standards from the WordPress Importer, it is because it is included in the theme. There is an open ticket about this issue on https://core.trac.wordpress.org/ticket/34679 We will update the importer as soon as an official solution is provided.

The reviewers did not flag this as an issue in our review process :slight_smile:


#6

Great , thanks for your response :slight_smile:


#7

No problem. Good luck in your review process! :slight_smile:


#8

I wasn’t so lucky to get through this so easily. The reviewer forced me to remove wp_get_http. There is working solution available on WordPress importer pluging suport section of WordPress. Org


#9

can you give me the link ?


#10

@codiux

https://wordpress.org/support/topic/notice-wp_get_http-is-deprecated-since-version-44#post-7767834


#11

it works well for you ? import all without failure ?


#12

Yes, it worked for me.