Trouble with Unship theme / Visual Composer from ThemeHippo


#1

Hi there.

I’ve bought four copies of the Unship theme from Themeforest. My client loves the look of the template, but communicating with the theme author has not been easy.

There is a copy of Visual Composer bundled with the theme, but the VC will not work properly – or at least didn’t on the first of the four sites I’ve built with it – until the theme authors accessed my wordpress admin and did something that made the VC work. I’ve set tickets requesting the theme authors go in and do the same thing to activate the VC on the next two sites I’m working on, but those tickets have been sitting untouched for a week now. Granted, I know this is the holiday season…but my client is getting very impatient, and honestly so am I.

I tried buying a separate license for the VC in an attempt to get around having to depend on the theme author to activate and update the VC, but it looks like I am at the mercy of the theme author because the VC was bundled with the theme.

I’m wondering if any other developers have had this issue with a bundled VC, and whether you were able to get around needing to have the theme authors intervene to make the theme work the way it is supposed to. Any pointers would be much appreciated.


#2

It depends what the change was that they made and what is not working? Do you know what it was?

Buying external copies of the plugin will rarely work because often the author customised the plugin somehow to suit the theme and adding a fresh full copy will either not work or fail to resolve the problems.


#3

Hi there. Thanks for the reply.

Unfortunately, I don’t know what the author did to get the VC working the first time around. I did ask what they did, and asked if it was possible for me to do the activate/updates of the VC myself, and they never responded to that.

As it stands now, the VC won’t load either on the back or the front end. All I see on a front end load is the logo/loading graphic, which just whirls around indefinitely. On the back end, the whirling of the logo/loading graphic does stop, but the UI of the edit page never changes to accommodate the VC boxes.

Unfortunately, this is my first experience working on a theme purchased at Themeforest/Envato, and as you can see it hasn’t been a good one. Is there a way that I can ask Themeforest/Envato to reach out to the theme author for me? I’m not sure what kind of recourse I have in this situation. Again, any info would be helpful.


#4

It depends when you bought the theme. You get 6 months support included so if it was within that period then the author should be helping you with it esp. if they have already identified a fix.

Usually the problem you are describing tends to be related to plugin versions or hosting but without looking into it then it’s difficult to say for sure. Are you using the most up to date versions of WordPress, the theme and plugins?


#5

Yep. I updated the wordpress version and all of the non-theme plugins before I installed the theme and everything that came bundled with it. I suspect that an older version of the VC comes bundled with the theme, and that is the plugin that needs to be updated.

I bought the first copy of the theme 2 months ago max, and the three additional copies only 2-3 weeks ago…which is why it is so frustrating that I’ve been at a standstill for a week now.


#6

The last update was in mid 2015 so the plugins will be substantially out of date and likely to have an issue with the latest version of WordPress.

If you are using non theme plugins then the first thing to do is to go disable them and see if doing this resolves the issue. Its not difficult (just disable in the plugins page), and if the theme don’t work as you want then what’s the worst that could happen?

If this does not fix it then you are within your 6 months support and the author claims to support the file so if you are not getting any response then you can open a ticket with support https://help.market.envato.com/hc/en-us/requests/new


#7

I case if you’re interested in:


#8

Ok. Just tried your suggestion of disabling all of the non-theme plugins, and I’m seeing the same issue. I’ll open a ticket at the link you’ve provided. Thank you very much for your help.