TGM - REQUIRED: class-tgm-plugin-activation.php.

After I add TGM plugin files to my theme I getting this error in theme check:

REQUIRED: class-tgm-plugin-activation.php. Themes should use add_theme_page() for adding admin pages.

Line 641: $this->page_hook = call_user_func( ‘add_submenu_page’, $args[‘parent_slug’], $args[‘page_title’], $args['menu_t

Is there any example how to fix this ?

Best Regards

you need to include above files when call this function so add include function in just above this lines.

I am facing the same error and can’t fix it. can you please elaborate the solution?