Text Editors auto focus problem


#1

I’ve got this problem and i cant seem to be able to find an efficient solution.



I am using a text editor (I tried both TinyMCE and CKEditor)

I can’t seem to find a way to disable the auto focus feature built into to.



My editor is located at the end of the page! I dont want to jump to that area when laoding the page. (Content is generated dynamically too)



Does anyone know about a fix or maybe link me to a text editor that doesnt behave like this!



Thanks!


#2

These should help :

TinyMCE : http://stackoverflow.com/questions/10944450/is-there-a-way-to-prevent-tinymce-from-auto-focusing-on-page-load

CKEditor, here you actually need to do the opposite (so setting startupFocus to false) : http://stackoverflow.com/questions/1944198/ckeditor-autofocus-on-the-text-editor-onload


#3

I’ve tried both. I’ve read their apis and tried a lot of stuff :S


#4

That’s weird man, do you maybe have a link to your page so I can see ?


#5

Thanks man. I cant spend more time on this silly problem.
I used a simple trick : I simply initialize the editor once the textarea is on screen. Thus no more page jumps.