Stuck on Loading Page of Visual Composer

Three weeks ago, everything was perfectly working on wordpress but starting last friday when I click “edit the page with visual composer” it just gives me a loading page. I have already done the following…

  1. I visited and confirmed that I have the latest browser, Google Chrome Version 50.0.2661.102

  2. Tried to disable all browser extensions or addons, still nothing happened.

  3. I also tried cleaning browser’s cache and cookies and disable extensions.

  4. I tried to do the content editing with all browsers I have, which are chrome, firefox and IE, but no difference.

  5. I have also tried to use a different laptop and computer


  1. What could have gone wrong?

  2. Do I need to update the network?

  3. Do I have to activate my License?


If you did some updates lately (WP itself, VC, other plugins/themes) and already completely cleared the browser cache, you might want to check the browser console (press F12 and click “console” tab in the appearing new window; depending upon browser, you might have to reload the page one more time to enable the console) to see if there are any JS errors generated by any scripts, that could prevent VC from initializing correctly. Should there be any error messages, it will also tell you which file (including path) is triggering the error, allowing you to trace the error back to a particular plugin or theme.

In general, issues like that should be directed to the support team from WPBakery, which is the author of Visual Composer.

I’ve disabled all other plugins, cleared my browser cache, rebooted my PC,logged in and attempted the change on a separate browser, tried it all on another computer in a different location with no joy. It still hangs on the visual composer loading page with the three boxes when I am trying to make a frontend edit.

Please assist.

Hello @Onosendai213

Please contact the author of Visual Composer (wpbakery) and they’ll be happy to assist you with this. You can reach them here:

Hello This happened to me before, after increase WP memory Limit my issue was solved.