slider revolution embedded video returns a 404 error

Hi - I need to embed a video in a slider. I have tried 2 methods and both return a 404 error when the page is viewed and you try to play the video.

  1. Add Layer: Video; paste the url and it renders the video. it plays fine in the slider, but returns a 404 in the page
  2. Add custom HTML, it renders fine and plays in the slider and returns a 404 when you try to play in the page
    i’ve updated the slider revolution, cleared my cache. same result.
    I need a fix please. i can’t find any thread; documentation or web search that addresses this.

I believe the problem is an Avada theme container issue. Not a revolution slider issue. As an example: Once before in dev. all the movies and links on a particular page would not function. there was a container that my engineer said was corrupt. I’d delete it, update and it would reappear. He couldn’t figure it out. I rebuilt the page and deleted the corrupt one. Everything worked fine after that. This is an intermittent bug in Avada.

I rebuilt the slider and the page. just in case. the video plays fine now.