Site help! -- Oshine theme (in Wordpress) -- Issue with vimeo embed

Hello everyone,
I could really use some help. I had my portfolio site built for me in Wordpress using the Oshine theme: (www.tvportfolio.com) and over the last few months, I am getting very frustrating “Your consent is required to display this content from vimeo” and next to it a link to “privacy settings” under all my VIMEO embedded videos. Even more frustrating, when you click “privacy settings”, it looks like the OSHINE theme itself is blocking it somehow, so there is no way for anyone to be able to actually view the videos on my site. Considering my site is my portfolio for all my work, this is unacceptable and a HUGE problem, as it makes my site utterly worthless.

Even worse, I found a slight workaround, whereby I can go into the dashboard and open the page in Tatsu, click save (even though I did nothing to the page), and then suddenly the page and video will display properly as a vimeo embed. However, this only lasts for a few days it seems, and then the problem restarts. This is unsustainable and I really need help diagnosing how to fix this.

Also, for anyone interested. I’ve found this on search: https://www.google.com/search?q=%22Your+consent+is+required+to+display+this+content+from+vimeo%22&oq=%22Your+consent+is+required+to+display+this+content+from+vimeo%22&aqs=chrome…69i57.1267j0j7&sourceid=chrome&ie=UTF-8

As you can see, even the BRAND EXPONENTS website on this search comes up with the same issue, which makes me think this is an inherent problem with the theme itself, and I am not skilled enough to figure out how to fix it. I tried reaching out to the theme authors a few times, but have not heard back at all.

Is there anyone on this forum that can help me figure this out? Thank you in advance for your help!! I will be forever grateful as I don’t want to have to build an entirely new site!!

Couldn’t figure out how to fix this problem… but if you insert code instead and embed the html it seems to work.