Revolution slider controls

I just purchased a few days ago the Warehouse theme with the revolution slider included. After watching some youtube videos on how to use it, I noticed my slider version’s controls show up (or do not show up) differently. Basically, the color palette button does NOT call up the color palette (I have to manually insert a hex code) and the letter spacing button is missing. Please see the attachment.

My version of the slider is 5.1.7

Any help is appreciated. Thanks

This could be because of Javascript errors, check console if you can, you might see some errors. If you have a fresh installation of WordPress without much customisation try contacting the author there might be able to help. You can contact the author here

Have you tried updating your plugin to the latest version 5.4?

The slider was bundled in the theme I bought, and from what I understand, I can only update it by paying…again. First I would like the slider that I paid for to work correctly, and then I may think of updating.

I’m not so sure about the javascript error possiblitlity. I’ve tried the slider on different computers and different OS’s with the same result.

I should add that I’m using the slider on Prestashop