Reviewer always said "Theme Activation Broken" issue after submitted a update


#1

Every time I submitted a theme update, it was soft-rejected by theme activation broken issue, but I activated the theme on my different website, it was normal. Sometimes, after I explained to the reviewer that maybe because the file permission or server configuration issue, they were approved the theme update.

I really confused that why the same issues always only happened on reviewer’s test site, is anything I missed?

Has anyone the same experience?


#2

Does the rejection also contain a screenshot to explain what actually broken?

Maybe they are testing the theme on a different environment, using different php / mysql versions.

I already had this problem, so I just set up multiple php versions in my server, then installed the theme on every single version. This fixed the issue listed by the reviewer.


#5

@ThemeSLR What’s version of your PHP / My SQL version?

I tested the theme under PHP5.2.4 AND PHP7+, the theme was activated as normal, and I turned on WP_DEBUG, there’s no error or warning information, it’s strange that it’s not working on reviewer’s test site.


#6

Then it should be ok.

Please make sure your have wp_debug true before adding the theme on your site.

The theme can trigger errors exactly after activation


#7

The reviewer show me the chrome developer tools > console info, http://envato.d.pr/4R4p/26KCyfnh

It’s strange that why it’s working fine on my 3 different hostings and sites.

Any suggestions?

Thanks in advanced!


#8

Have you tried to install/activate the theme on a localserver? WAMP, MAMP?


#9

Yes, I use MAMP for my local test site. But those error information looks like not the theme issue.


#10

You should ask the reviewer what environment he is using and what steps he made to get the error.


#11

###Possible causes:

  1. Have you tried to check the frontend of the theme immediately after activation? Without any plugin installed?

  2. Does your theme comes with Child Theme? If yes, activate it and see if you get these errors. Those errors can be caused by a bad configured Child Theme :slight_smile:

Regards


#12

Yes, it’s working without any plugins activated, no child theme.

That’s strange. I often received this kind of issue when I submit updates. Sometimes, I told the reviewer that maybe because of network reason? cache? or server configuration, they approved.

I have no idea.


#13

Using Mamp with PHP 5.6. I tested it with the same environment, can’t reproduce the issue…

http://envato.d.pr/AXfz I found there’s not only the theme resources file wasn’t loaded, but also some plugins js/css files…


#14

It’s the same reviewer? If yes then something is misconfigured on his end or he has an htaccess file which is blocking file accessing or a browser extension.


#15

It’s not the same reviewer :frowning:


#16

Try to explain this problem to the reviewer.

I you don’t get a favorabile result from the reviewer then you should submit a ticket to envato, explaining the issue. Then, simply add the ticket numbet(if you got a good reply from Envato Support team) on message boz when resubmitting the item.


#17

Thanks, I will try.