RAM preview is not working


#1

I often have a problem with the RAM preview. Sometimes i cant see a ram preview and get this error message: RAM preview need 2 or more frames to…

I HAVE 2 or more frames to render, but it doesn’t work.

Any solution?


#2
BoostShock said

I often have a problem with the RAM preview. Sometimes i cant see a ram preview and get this error message: RAM preview need 2 or more frames to…

I HAVE 2 or more frames to render, but it doesn’t work.

Any solution?

not enough RAM memory. Always render preview at half or quarter resolution.


#3

I tested every resolution and always the same message.

Now I checked my RAM and saw that AE is taking about 2m of my RAM. Why?

I have a Quad core with 4gb RAM.


#4
BoostShock said

I tested every resolution and always the same message.

Now I checked my RAM and saw that AE is taking about 2m of my RAM. Why?

I have a Quad core with 4gb RAM.

did you set the preview range correctly? It happens sometimes if you left left and right marker next to each other.


#5

Everything is fine, if I take “from current time” and bring the indicator to any place ad render, it only plays 2 frames.


#6

It happens sometimes to me for no reason, and everything is fine when I simply restart AE :slight_smile:


#7

Try to “Purge all memory” but don’t know why, AE tends to build up usage of memory and does not clear it completely as we want it to. So safest way is to follow dorde’s advice. restart AE. Don’t know if that is happening in 64bit cs5 version.


#8
ivezicm said

Try to “Purge all memory” but don’t know why, AE tends to build up usage of memory and does not clear it completely as we want it to. So safest way is to follow dorde’s advice. restart AE. Don’t know if that is happening in 64bit cs5 version.

Purge doesn’t work in this situation, only solution is restart AE ( dorde +1 :slight_smile:


#9

Thanks guys!

little bit annoying to restart ae while I am working om a project.


#10
Balistique said
ivezicm said

Try to “Purge all memory” but don’t know why, AE tends to build up usage of memory and does not clear it completely as we want it to. So safest way is to follow dorde’s advice. restart AE. Don’t know if that is happening in 64bit cs5 version.

Purge doesn’t work in this situation, only solution is restart AE ( dorde +1 :slight_smile:

Try to clear database (EDIT>MEDIA&DISK CACHE)


#11

For me, changing preview resolution always helps


#12
vaynah said

For me, changing preview resolution always helps

For me not.


#13

Is this situation appearing on every project you work on? Even with simplest bg and text layer? Check this one out. If it’s not showing up on simple project (one or two layer’s), than you’re having memory issues.


#14
miseld said

Try to clear database (EDIT>MEDIA&DISK CACHE)

You mean Preferences > Media & Disk Cache?

This won’t solve much, since this is a disk based cache used to cache hard to decode formats like mpeg and mp3 to a more quickly and readily usable format.

-f.


#15
Balistique said

Purge doesn’t work in this situation, only solution is restart AE ( dorde +1 :slight_smile:

That’s not true either. Purging the RAM should be your first port of call in this situation. Then a restart if required. Works for me, anyway.

-f


#16

@Boost

The erroneous 2 frames message, pretty much means you’re out of RAM.

You have to understand that After Effects does all sorts of behind the scenes caching. It doesn’t recomposite every frame from scratch every time. It renders interim stages too, so that for instance adding an adjustment layer at the top of a 4 comp deep nested structure doesn’t cause the whole thing to have to be re-rendered.

Also, for instance, if you switch to half res from full res, you don’t immediately free up RAM, because the full res previews and many of the in-between stages of the previews remain cached, so when you switch back you don’t have to start from scratch.

Having disk cache on will help some as it allows AE to put some of the less crucial cached parts into a temp folder on the HD… slower to recall, but at least those parts don’t need to be reprocessed/re-rendered every time.

You can also manually control caching by rendering pre-comps as stages of your project and then setting this as a proxy for the comp. (you can set this to happen in the Post-render Action of the Output Module too)

A particularly gargantuan project, having tons of comps / windows open, having audio waveforms showing, have your entire project twirled down etc. etc. all take up RAM too and all have an effect on what’s left for previews. Try to work efficiently and only have those windows open that you need to.

If you’re rendering previews with MP, you might also want to try rendering them without.

-f.


#17

Oh yeah… and my top tip for RAM issues…

DON'T USE MASSIVE IMAGES.

(it needed to be shouted) :smiley:

if you have a 6000x4000 jpeg, don’t just bring it in. Scale it down in Photoshop to the optimal size, then import.

I don’t know why, but big stills are pretty much guaranteed to bring After Effects to a grinding halt.

-f.


#18
a disk based cache used to cache hard to decode formats like mpeg and mp3 to a more quickly and readily usable format.

-f.

while we are talking about it, my AE tends to crash while previewing with audio holdin down ctrl button and sliding CTi through to hear what is going on. I’m using mpr. What audio format is most friendly for AE in order to keep avoiding AE crashing.
thnx for answers


#19
ivezicm said
a disk based cache used to cache hard to decode formats like mpeg and mp3 to a more quickly and readily usable format.

-f.

while we are talking about it, my AE tends to crash while previewing with audio holdin down ctrl button and sliding CTi through to hear what is going on. I’m using mpr. What audio format is most friendly for AE in order to keep avoiding AE crashing.
thnx for answers

-inlife


#20

thnx