querious problem


#1

Hello i have just buy querious http://www.araelium.com/querious/

but when i have type all my info it ask for “socket” and i dont know what it is and what to type, and then i try to just press “connect” it says:

“Querious failed to connect to the database server localhost.
Can’t connect to local MySQL server through socket ‘/tmp/mysql.sock’ (2)”

what can i do to fix it?

  • Simon

#2

I assume your MySQL database is on the internet somewhere (different host).

I am a windows user and use SQLYog, however! Which method are you using to connect? 100% of the time I will connect via the SSH Tunnel instead of the straight connection (as this is usually blocked off).


#3

no i use local database (mamp) but i dont know what “socket” is,


#4

i need jeff :smiley: im lost


#5

The Application is basically looking for the socket (connection) information from that file, but it cannot be found.

I did a quick search for that error and OSX and here is a blog post on how to fix it.

http://verysimple.com/2009/01/07/php-on-os-cant-connect-to-local-mysql-server-through-socket-varmysqlmysqlsock/


#6

the blog post dident help me :(, but on the mamp frontpage that pop ups when you start mamp it says i can use this “/Applications/MAMP/tmp/mysql/mysql.sock” so i try that and now it works :slight_smile: havent seen that before.

but it works now so thanks for your help :slight_smile: