Problems installing News theme


#1

Hello. I can’t properly install the News theme. I get this error message below after I uploaded the theme to the theme directory. I also tried to upload the theme from within Wordpress with a similiar error message. How to fix this?

Error message: “Newspaper. Template is missing. Standalone themes need to have a index.php template file. Child themes need to have a Template header in the style.css stylesheet.”


#2

Hello @klassiskahomeopater

Are you trying to install a child theme? This error message appears usually when a child theme with an incorrect header in style.css is installed.

Inside the child theme you are trying to upload, there is a style.css file that should have a header something like this (not identical to this):

/*
Theme Name: News
Theme URI: http://themeforest.net/news/
Description: News theme
Author: John Doe
Author URI: http://themeforest.net
Template: news
Version: 1.0.0
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html
Tags: light, dark, left-sidebar, responsive-layout, accessibility-ready
Text Domain: wpnews
*/

If this doesn’t solve the prolem, here is a short and easy article explaining how you can contact the author of the theme for more help: https://help.market.envato.com/hc/en-us/articles/203039054-How-to-contact-an-author


#3

Hi, I have a problem trying to download the theme to wp, it says: El archivo subido excede la directiva upload_max_filesize en php.ini.

Any suggestion? thanks


#4

Hi @hectoran40

you’ll have to increase upload_max_filesize.

Please try one of these methods:

  1. via php.ini file.

If you are on a shared hosting, most probably this is the solution that will work for you:
create an empty file named php.ini and save it in the root of your WordPress folder. Then put these lines in it:

upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 500
  1. via the .htaccess file

Create (or edit, if you have it already) a file named .htaccess in the root folder of your WordPress folder. Then put these in this file:

php_value upload_max_filesize 64M
php_value post_max_size 64M
php_value max_execution_time 500
php_value max_input_time 500

#5

Hi Hevada. Thanks for your reply. I have fixed it now.